Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 1/25/2006 7:52:10 AM EDT
With a loaded mag securely in the weapon I'll pull the bolt back and let it go,it chambers the round but is about 1/2" away from being fully closed.

Any ideas? Yeah I know it's a cheapo Century but I did expect it to work out of the box

Would pics help?
Link Posted: 1/25/2006 8:21:42 AM EDT

Originally Posted By Ghetto:

Would pics help?



yes, take out the carrier and bolt, and take a picture of both.

it might be the installment of the rails on the receiver.

can you manually close the bolt onto the round with enough force?
Link Posted: 1/25/2006 8:25:05 AM EDT
I really didn't want to force a live round,but the bolt closes perfectly with an empty mag or with no mag,kinda weird.

I'll post pics in just a sec.
Link Posted: 1/25/2006 8:31:55 AM EDT
PICS!!









Link Posted: 1/25/2006 9:07:08 AM EDT
Link Posted: 1/25/2006 9:30:48 AM EDT
[Last Edit: 1/25/2006 9:35:01 AM EDT by 1Gunner]
I bet your extractor is rusted or gummed to the point where it won't rotate and accept a round case lip

clean your extractor!!!!! It's that claw on your bolt face, see if you can make it pivot

and while you are at it clean the rest of you damn rifle!
Link Posted: 1/25/2006 9:37:15 AM EDT
yes, it does look caked in cosmo, although that usually won't stop an AK from functioning properly.

Take it apart to the last screw, clean off all the cosmoline, and reassemble.

and try to push a round into the chamber manually (without the bolt).


-mark
Link Posted: 1/25/2006 9:43:42 AM EDT
Heck and I thought the thing was decently clean,guess not LOL.

I've got a real good AK/SKS guy who only works on Saturdays,I'll bring it to him and let him go through it,heck he enjoys it. I'll take it apart and try the round in the barrel without the bolt and see how it fits.

Thanks guys!!
Link Posted: 1/25/2006 12:29:33 PM EDT
I had the same problem with my old wsar-10...I would put in a 30 round clip and pull back the bolt and let it slam and 1/2 the way threw it would stop the same way. Then I pull the bolt back again to extract the round and then repeat the process again then it would work fine...after it would keep doing that on the first round I just got tired of the damn thing and cleaned the hell out of it again and got diff mags and then it worked fine.....I only had that problem with wasr-10's not any sar-1's or saigas.....give the extractor a good clean just like gunner said and u should be fine.
Top Top