Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 5/22/2003 10:34:24 AM EDT
[Last Edit: 7/8/2003 11:23:22 AM EDT by GLOCKshooter]
I installed one in my Maadi. took it to the range. Pulled the trigger. Bang. Tried to pull the trigger again. No pull, no bang. Worked the action. Live round popped out. Pulled the trigger. Bang. Tried to pull the trigger again. No pull, no bang. Worked the action. Live round popped out. Pulled the trigger. Bang.


What should I do?
Link Posted: 5/22/2003 11:33:20 AM EDT
[Last Edit: 5/22/2003 11:42:23 AM EDT by drjarhead]
With firing is the bolt going all the way home? Push on the handle(safety on first) and then try. I'll bet it isn't. Maybe internals hanging up bolt a little. A little stoning required or just some break in maybe.

Try taking the top cover off and working the action. Pull trigger, etc. Do so unloaded of course. What happens.
When you work the action is there a lot of force required to pull bolt back? There should be a little bit of "hang up", for lack of a better term, but it shouldn't prevent functioning.
If it is short stroking due to hangup on the hammer and disconnector you would have this problem as the hammer is not being locked down on return of the bolt/carrier. Hence, no pull. Fire it and put on safe. Remove top cover. What do you see? Pics would be great.

Also, are you sure that the retainer is properly placed and that trigger and hammer pins are fully in place? That could definitely lead to the above problem. Eventually will work themselves out of the receiver also.

Disconnector and spring properly installed?? The disconnector spring should be fully seated into the hole for it in the trigger.
Link Posted: 5/22/2003 11:47:21 AM EDT
[Last Edit: 5/23/2003 3:42:34 AM EDT by CAMPYBOB]
Link Posted: 5/22/2003 7:00:19 PM EDT
Mine did the same thing.
r.s. does not give a new sheppards hook.The old one,abused as it is,allowed the hammer pin to move enough so that the hammer wouldn't catch unless the action was moved by hand.
Using WW ammo, I had a double.
New wire fixed it.
Link Posted: 5/22/2003 7:28:57 PM EDT
Link Posted: 5/23/2003 9:01:12 AM EDT
The bolt is travelling back far enough to strip a new round, So I don't think that's the problem. It is going all the way forward, and the hammer is following it. The hammer is simply not catching on the trigger for whatever reason. It ran like a, well, like an AK before I replaced the trigger. I just sent an e-mail to Ken in response offering a plate. I'll put it in and see if it helps.
Link Posted: 5/23/2003 9:51:48 AM EDT
However, everything is working properly when you cycle the action manually, is it not?

That's what makes me wonder about it short stroking for some reason and if that is the case and the only thing different is the FCG...

It might still strip a round but not reset the disconnector if this were the case. I guess the question really is what happens internally that is different with manual vs auto cycling?

Link Posted: 6/9/2003 8:59:48 AM EDT
Follow up e-mail sent.
Link Posted: 6/10/2003 5:08:38 AM EDT
i'm having trouble with my red star arms trigger set too, i got it set for 4 lbs and i keep getting 2 round bursts, somtimes it has the live round problem glock is having. i did n't have these problems before with the old group. i love how smooth the red star is. i must have done somthing wrong when i had it put in. i will keep you guys updated
Link Posted: 6/10/2003 8:26:22 AM EDT

Originally Posted By 1179:
i keep getting 2 round bursts,



Great. Now the JBT's are going to burn down your church and execute your dog.


On a seperate matter, e-mail reply received. Thanks.
Link Posted: 6/13/2003 10:19:16 AM EDT
Retainer plate received in today's mail. Probably can't hit the range till Tues. Will advise.
Link Posted: 6/19/2003 8:59:21 AM EDT
Replaced shepards crook with plate. Pins were defeinitely all the way in this time. Same drill at the range, exactly (fire, no pull, live round in chamber, hand charge, fire, no pull...). checked pins again. They had not walked out at all.

Checked action. No unusually difficult hang up, no extra force required to charge. After firing the new round was completely chambered, the only issue was the hammer was down instead of back.

I have not yet moved any of the set screws at all. I left them factory original. My next thought is to adjust the disconnector screws.
Link Posted: 6/19/2003 9:28:28 AM EDT
After firing where is the hammer?

Probably FCG needs some adjustment. RSA will so this for you just in case you don't know that. And it's free of charge, IIRC. Only shipping.

I did post on FCG adjustment somewhere around here last week. I asked Bob about it when I did mine and between the instructions and Campybob's tips I got that thing set up just right.
Link Posted: 6/19/2003 11:01:56 AM EDT

Originally Posted By drjarhead:
After firing where is the hammer?



"After firing the new round was completely chambered, the only issue was the hammer was down instead of back."

Link Posted: 6/19/2003 2:30:54 PM EDT
Link Posted: 6/19/2003 2:57:32 PM EDT
ken i imed you with my problem did you not get it? i'm still having 2 round bursts and i have adjusted my trigger any help would be apprciated.
john
Link Posted: 6/19/2003 4:39:35 PM EDT

Originally Posted By KenR_RedStarArms:
GLOCKshooter. What kind of AK do you have? If it is like any of my test guns I have in the vault I will set up a trigger for you and ship it out right away. Just tell me how you want it and I will make it happen. When you get the new trigger just send the old one back parcel post.

Let me know if this will work for you.

Ken Roberts
RSA



Ken,

Although I am honestly a little frustrated, I do appreciate your effort at correcting the issue.

There is a wide variety of AK's I will try to zero you in the best I can.

It is a Maadi MISR S/A. Post ban. 16". no muzzle device. It was originally all Egyptian except the FCG, so I had to use US floorplates and followers until I switched out the furniture (so the piston is also Egyptian). It is not the MISR 10. Not the half Egyptian, half chinese. It is designed as a double stack, not a dremelled out single stack.

The Red Star trigger is a 6th gen from sportsman's guide www.ar15.com/forums/topic.html?b=4&f=64&t=55336&w=searchPop

As to settings, in a perfect world I would like a 2 stage with a short take up followed by a clean break that was light but not hair (4-5 lbs?). Im used to a GLOCK 35 with a 3.5 lb trigger.

In reality what I was looking for and will be happy with is a FCG that is easily identifiable by sight as US (the one that came in the Maadi only had stampings on one part, but due to the tab on the trigger it is obviously US, I just don't want any possible argument from the JBT's) and that does not have slap.
Link Posted: 6/19/2003 6:01:15 PM EDT
Link Posted: 6/19/2003 6:19:33 PM EDT
Heheheh. Life's a bitch.

You ought to see all the nasty crotches I gotta look at. Yuck!
Link Posted: 7/8/2003 8:36:57 AM EDT
I'm going to the range tomorrow, so I dremelled the tab off my old disconnector and reinstalled the entire old FCG. Hopefully that will solve the slap.
Link Posted: 7/8/2003 4:44:25 PM EDT
Link Posted: 7/9/2003 4:16:00 AM EDT
Whatever. I've written the cost off and fixed my problem.
Link Posted: 7/15/2003 10:44:02 AM EDT

Originally Posted By KenR_RedStarArms:
No trouble I have a Maadi setting right here I will use to set up a 2 stage for you and get it out by Monday.



Received a one stage trigger sometime between Friday and today (Tues). Not sure when, I ended up in the hospital Fri. (I'll be fine). I'll mail back the first RSA trigger and $ for the retaining plate (had nothing to do with the malfunction, but is worth keeping).

I won't be able to shoot for a month, so I have no idea if the new RSA works or not. Assuming it does, I should be able to adjust it to 2 stage with the enclosed instructions.
Link Posted: 9/10/2003 12:42:13 PM EDT
Finally cleared by the doctors. Took longer than I thought, but now I'm back in the game.
New trigger group did not install as pre set. Had to ajust to get it to fit into the rifle. Took it to the range. Same problem, triiger would not re-set. Turned my AK into a single shot. Put the old dremelled parts back in. Works fine, no slap. Both RSA trigger sets and $12.99 for the retaining plate will be in the mail to Ken at RSA tommorow.

My Maadi S/A is obviously different than the Maadi AKM. AK's have a lot of variations. The RSA simply is not "drop in" for MY rifle. Thanks for trying.


Top Top