Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 2/6/2006 6:44:03 AM EDT
My first build seems to have a problem. it shoots fine from the shoulder and pretty much as fast as I pull the trigger. However, when I bumpfire it, It will only pop off 3 rounds.
pop, pop, pop, nothing. on the "nothing" - a round is chambered but the trigger is not reset for that pull.
Ill drop mag and eject cartridge, it shows a light primer strike.
insert mag, rack it, bumpfire -- pop, pop, pop, nothing -- light primer strike.

the hammer does not reset, and I think it somehow follows the bolt/c.h. forward and may push the pin into the primer for the light strike.

why, oh why?
am I just too damn fast for my own good?
I dont need to bumpfire, but this is part of my function test, im not satisfied until all 30 are down range.

anybody know anything about this. Is there a solution?

thanks,

BPH
Link Posted: 2/6/2006 4:12:08 PM EDT
[Last Edit: 2/12/2006 9:06:08 AM EDT by BLM]

Originally Posted By BurntPocketHole:

the hammer does not reset, and I think it somehow follows the bolt/c.h. forward and may push the pin into the primer for the light strike.




thats exacty what is happening becouse it is not designed to bumpfire
I am not saying I dont bump fire why the hell not
what kind of trigger group is in it?
It could be that you just need a little trigger work

ETA deleted some shit becouse BSGO1 doesnt know how to read I never said you need full auto parts to bump fire. I said you you would need a full auto gun to work right so you dont blow your damn face off when the hammer followes the bolt and may make the round go off out of battery
Link Posted: 2/6/2006 5:50:10 PM EDT
G2, I cant remember if its SH or DH, that shouldnt matter though.
I Built another AK right after this first one and it bumps fine, the mag fit is extremely tight tho, and i had to grind a couple tabs down on the mags ( where it locks into the mag release).
Link Posted: 2/7/2006 10:51:23 PM EDT
Has ANYONE else ever had this problem???

I experienced it with another ARFer's AK Pistol... so someone else has to have dealt with it.

maybe Im just losing it...

BPH
Link Posted: 2/8/2006 7:44:37 AM EDT
Sounds like your just pulling the trigger to fast.
Link Posted: 2/8/2006 8:38:00 AM EDT
rifles alittle tight
wait till you break it in that will go away

congrats on your first build
Link Posted: 2/8/2006 8:39:34 AM EDT
also you need to mod the rifle not the mags
you want to be able to use any mag not just 1 you have messed wit
Link Posted: 2/8/2006 9:46:19 AM EDT
+1 on this topic. I build 2 Yugo M70s that do the same exact thing. They bump a few rounds then nothing. They shoot perfectly fine otherwise. After talking with other AK builders that I know our thoughts were that the springs may be weak? I am using a G2 single hook triggers as well. I even looked with the cover off and it should be catching every time. I dont see why it wont. Help on this matter would be lovely
Link Posted: 2/8/2006 4:34:42 PM EDT
Too much rear motion of the gun causing the bolt carrier to travel incompletely to the rear thus not reseting the trigger (cause by your not holding the grip firmly)

Cheap solution, bump with a sling over left sholder adjusted to correct height. It helps with the bump and control. Aslo try to help the bolt carrier travel rearward by polishing the flat on the underside and the matching face of the hammer. This reduces the resistance and allows the carrier to travel rearward more easily. Just some thoughts.
Link Posted: 2/11/2006 11:13:26 PM EDT
So basicly, hold the gun more firmly and polish the surfaces for the carrier and the hammer face.
Link Posted: 2/12/2006 8:40:55 AM EDT
thats BS. you dont need the full auto parts to bump. plus i wouldnt recommend
installing those.
Link Posted: 2/12/2006 9:07:41 AM EDT

Originally Posted By BSOG1:
thats BS. you dont need the full auto parts to bump. plus i wouldnt recommend
installing those.



never said that read my post
Link Posted: 2/12/2006 10:34:16 AM EDT
ETA deleted some shit becouse BSGO1 doesnt know how to read I never said you need full auto parts to bump fire. I said you you would need a full auto gun to work right so you dont blow your damn face off when the hammer followes the bolt and may make the round go off out of battery


who the heck is BSGO1 ???
thats not how i read it before. and what the fuck do i really care what you do.....
i dont recommend using said parts. thats all i said. hey ,maybe my misunderstanding.
Link Posted: 2/12/2006 10:49:03 AM EDT

Originally Posted By BSOG1:
ETA deleted some shit becouse BSGO1 doesnt know how to read I never said you need full auto parts to bump fire. I said you you would need a full auto gun to work right so you dont blow your damn face off when the hammer followes the bolt and may make the round go off out of battery


who the heck is BSOG1 ???
thats not how i read it before. and what the fuck do i really care what you do.....
i dont recommend using said parts. thats all i said. hey ,maybe my misunderstanding.




my bad on the name I FIXED IT I am not trying to piss anyone off I just worded my original post wrong
sorry maybe I took it the wrong way
Link Posted: 2/12/2006 11:05:29 AM EDT
no problem , just dont want to see ar15 brothers getting in trouble for stuff thats not
necassary . global, kvar, g2, all offer super awesome parts. no trigger slap, smooth break.etc...

shoot on-------->
Link Posted: 2/13/2006 9:50:17 AM EDT
Ok, no one still really answered the question. Oh well.
Link Posted: 2/14/2006 1:53:04 PM EDT
[Last Edit: 2/14/2006 1:58:21 PM EDT by BurntPocketHole]
OK, I took my 3 AK's out this weekend, this is what I came up with.


BLM and Santanatwo are on it

the "stall" happened to both of my home builds, both G2's. I think it happens when you get sloppy and the trigger doesnt reset since youre ahead of the cycle. Im still not exactly sure though. It seems to happen more in one than the other

-maybe the actions are attempting to shoot the next round before the bolt and hammer can lock in all the way.
-if youre on the trigger- the hammer cant seat so it just rides back forward with the charging handle?

another thing-
I can achieve HIGHer rates of fire on the Tapco G2's, than I can on my Arsenal Sam-7's trigger.
(shooting normaly from the shoulder, Not bumpfiring).

The rate I hit on the G2's IS quite similar to Bumping and I can empty a mag, almost as fast as bumping. BUT, it has to be consistant in order to avoid the stall out AND you need to find the sweetspot.
BS you say? (I have fast fingers, and i could hit the rate quite naturaly after 6 years of tournament paintball).

I didnt really reach any REAL conclusions.
Next, I think I will polish the internals on one and keep the other stock inside as a control to see what happens. Maybe I am just shooting too fast, but I will have to tell you after the next case of ammo. I need to see if its just breaking in, like Socandy said

Link Posted: 2/14/2006 8:06:51 PM EDT
I messeed with mine today when I was cleaning that there IS a point where if you are doin it just right that there is enough distance between the disconnector and the trigger catch that the hammer can miss sometimes. With that thought, could I lightly file down the bottom of the disconnector so it pivots forwards more to take up some of this slop?
Link Posted: 2/15/2006 6:29:42 PM EDT
Try the sling and polish the hammer bolt surface a little
Top Top