Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 3/13/2006 4:34:48 PM EDT

Hi guys: I have a dmps 24" ss bull barrel that I am having a FTF problem on any ammo and mag.

I have gone threw the trouble shooting list and found the gas tube worn out on the end and the gas block misaligned to the barrel port. I relpaced the gas tube and fixed the alignment. But still having the problem. I did the one round test many times and all locked back ever time. I have used different B/C/CH and different lowers, no change. Sometime the shell eject fine but the next round does not feed and good percentage of the time it stove pipes. Last time at the range when I pulled the mag to clear the mess the next round in the mag the copper had gone from shinney to dull purple in color like it had been heated. I do not know if that is normal. The barrel shoots great but before I replace the upper receiver maybe some one has an idea on what I could check next.
Link Posted: 3/13/2006 7:22:22 PM EDT
Link Posted: 3/13/2006 8:17:43 PM EDT
Stove piping --- the spent case is caught by the bolt. The primer end is being help by the bolt and the rest of the case is sticking out of the ejection port. I'm not sure but I think the next round has also been pushed forward. I have to drop the mag to clear it. If I pull the CH this puts the third round into the works. I hope this helps
Link Posted: 3/13/2006 8:51:16 PM EDT
[Last Edit: 3/13/2006 8:57:09 PM EDT by Dano523]
Link Posted: 3/14/2006 6:48:25 AM EDT
Link Posted: 3/16/2006 1:59:56 PM EDT
Dano

I will check all the things you talked about. BUT, my problem happens with several different bolts and carriers. I have mixed and matched 8 different bolts and carriers even used differents lowers and they came from ar's that work with no problem.

When you talk about pulling the carrier back and the face of the bolt should be 1/4" infront of the ejector port. Is that right???? I looked at all 8 of my ar's and none of them line up this way. They are either even or back 1/4" behind the ejector port.

Back to my problem-- I am going to try the o-ring and maybe look into a not buffer spring. Any of other ideas
Link Posted: 3/17/2006 4:18:11 PM EDT
Top Top