Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 3/12/2006 8:45:37 AM EDT
I noticed saturday after hunting, my unfired round from the chamber had firing pin marks as well as all the other rounds chambered. Obviously it wasn't struck hard enough to fire, but it has me concerned. This happened on my handloads with CCI 450 primers and my factory Remington Premier Varmints. Am I worrying too much? I don't want to shoot my calling partner by mistake, or have to explain a dishcharge in the farmers driveway.hinking.gif I'm shooting a RRA 24" SS bull flattop upper on a RRA NM A2 lower. All parts are RRA, and factory installed.
Link Posted: 3/12/2006 8:47:12 AM EDT
light firing pin marks are ok/normal.
Link Posted: 3/12/2006 9:03:47 AM EDT
It's normal... all AR15/M16 does that. AR15/M16 rifles were manufactured with an inertia type non-spring loaded firing pin. When you charge the bolt home, the firing pin is floating there and will tag the primer. Military spec ammo contains thicker/harder primer so it was never a issue before. There was talks a long time ago about slam fire when someone was using real soft primers... but I never witness this myself, nor have I had any issue with commerical ammo.

I heard that the use of a titanium firing pin resolve this issue if it bothers you... but I never try it myself since I never had this issue. But than, all I shoot is surplus mil stuff. If it bugs you, spend the $30 and get the titanium pin...


~nb
Link Posted: 3/12/2006 9:06:56 AM EDT
Normal
Link Posted: 3/12/2006 11:27:35 AM EDT
Thanks guys, I can't believe it took me this long to notice. I feel more at ease knowing what the deal is now. Will probably be more careful about charging rifle and make sure I'm out of vehicle and pointed in a good direction.
Top Top