Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 3/2/2006 9:11:42 AM EDT
[Last Edit: 3/2/2006 9:11:42 AM EDT by munyguru]
Also, it's hard to close the upper and lower.
There's only ONE way these can go on........so I don't get it.
Stumped.
I tightened the mag catch, to remove slop in mags( may be the double feed issue), but havent had time to try it.
The new stock, has good buffer,.....and is milspec as far as i can tell.
Should I try a weaker spring??.
Link Posted: 3/2/2006 6:15:39 AM EDT
Most double feeds are caused by mag failure. If you have a mag with a wolfe spring or a Colt mag see if that works. I would also try posting this in the AR15 forum.
Link Posted: 3/2/2006 9:44:45 AM EDT
[Last Edit: 3/2/2006 9:45:29 AM EDT by Gamma762]

Originally Posted By TwoShoes:
Also, it's hard to close the upper and lower.


It's possible you threaded the buffer tube too far in to the lower, so it's protruding into the lower and the upper is being pressed into the threads when closing. You'll see gouges in the upper next to the charging handle slot if this is the case. If this is the case, the bolt isn't traveling as far to the rear as it should, this could be contributing to the malfunctions.
Link Posted: 3/2/2006 9:58:04 AM EDT
[Last Edit: 3/2/2006 10:00:04 AM EDT by Dano523]
Link Posted: 3/2/2006 7:44:07 PM EDT
Link Posted: 3/3/2006 6:00:47 AM EDT
[Last Edit: 3/3/2006 6:01:37 AM EDT by Dano523]
Link Posted: 3/3/2006 6:01:19 AM EDT
Top Top