Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 11/26/2003 9:02:34 AM EDT
Im a newbie so please excuse me if this is a basic problem.

I have a problem with a round not being loaded from a mag when I use the charging handle. But, if I lock back the bolt, insert the mag, then release the bolt, it picks up the round fine.

Unfort, I have not have the time to experiment with different mags yet, to see if it happens with dif mags

Is this a mag spring problem?
Link Posted: 11/26/2003 9:25:44 AM EDT
Don't ride the charging handle back forward!!! Pull the charging handle all the way back, then release. This will allow the carrier to run forward under full power, strip the round, feed it, and the charging handle to lock back into the upper receiver. If you ever feel the need to Ride the charging handle back forward to be quiet, use the forward assist to add in charging the weapon. P.S. If your not riding the charging handle forward, then chances are the firing pin is binding up on the hammer, and you will need to relieve the top of the hammer to allow it to glide past the firing pin at charge.
Link Posted: 11/26/2003 9:40:52 AM EDT
thanks.. I should have added, that I did NOT ride the handle and I did pull it completely back. Is the firing pin against the hammer is not something that I can see. how can I tell if its happening?
Link Posted: 11/26/2003 9:46:18 AM EDT
[url]http://www.ar15.com/forums/topic.html?b=3&f=66&t=175139[/url]
Top Top