Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 11/7/2003 8:48:50 AM EDT
I just received my BUIS and am attempting to install them onto my brand new, never before fired, DPMS flat top upper.

The problem Im having is that the BUIS wont slide onto the rail far enough to lock in place. Its only half way onto it. Am I not applying enough force to get it on? I wouldn't think it should be that hard, thats what the lock screw is for. This is the first time Ive installed anything onto a flat top so Im hoping its just my stupidity and not a part compatability. Im trying to install it from the rear of the rail, with the charging handle extended back.

Thanks!
Link Posted: 11/7/2003 9:03:19 AM EDT
Sounds like something is a bit out of spec. Try tapping it with a rubber mallet. Not too hard, but some force may be required to get it on. If it seems that it will require too much force, try the sight on a Bushy, RRA, Colt, or Armalite upper if possible to help rule out the sight.
Link Posted: 11/7/2003 12:34:44 PM EDT
Romwin, You may want to do a seach on the other forums. I dimly remember several other folks having this problem with the ARMS BUIS. Therefore you may not want to force it onto the upper. It may not come off. If I run across what I'm remembering I'll post it here.
Link Posted: 11/7/2003 12:40:12 PM EDT
I think this is the one Tweak was talking about [url]http://www.jobrelatedstuff.com/forums/topic.html?b=3&f=18&t=170461&w=searchPop[/url]
Link Posted: 11/7/2003 1:21:32 PM EDT
G-CODE, That looks like the one. Thanks.
Link Posted: 11/21/2003 4:17:02 AM EDT
You may want to double check the dimensions of the #40 ARMS sight. I recently installed one on a Colt upper and the fit was very snug. I'm beginning to think that the ARMS dimensions are slightly on the small side and that the fit problem does not lie solely, if at all, with DPMS. --dulcenota
Link Posted: 11/21/2003 4:28:59 AM EDT
WOW a "part" you actually have to "fit"? what a concept! it's like we are real gun smiths and not playing with LEGOs
Link Posted: 11/21/2003 4:35:16 AM EDT
[Last Edit: 11/21/2003 4:36:17 AM EDT by Yojimbo]
If it won't slide on unscrew the nut all the way off and take apart the ARMS 40 then put it together on the rail and tighten everything down. I wouldn't hammer anything together, it's much easier to take it apart...
Link Posted: 11/22/2003 9:31:24 AM EDT
even if you take it apart the problem will remain, the rear section is to narrow the slide over the flatt top. I hade the same problem and very carefully filed the inside lower "hooks of the #40 until it wold just lied on by hand snugly, it fits very well and no external finish was removed. Mine owuld not fit on 2 different flat tops so I assume the #40's can tend to run on the tight side. Jeff
Top Top