Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 10/28/2003 4:32:30 PM EDT
Hey, maybe you guys can help me out. I have an Armalite M15 (20 inch) rifle that just doesn't want to cycle.It load a cartridge when cycled by hand, fires, but the bolt and carrier stay in place.I can hand cycle the action and the case comes out, no extraction or ejection problems.I tried the upper on my M4 lower with a different bolt group and it cycled, but not every time.I did change the gas rings on the bolt, maybe that was enough to F'it up?
Any ideas?
And if you know a trick to installing rings let me know.
Thanks
Link Posted: 10/29/2003 12:21:44 AM EDT
[Last Edit: 10/29/2003 12:23:53 AM EDT by Tweak]
Originally Posted By G3k: I tried the upper on my M4 lower with a different bolt group and it cycled, but not every time.
View Quote
In order to troubleshoot effectively you must not change out more than one part w/o test firing. You switched lowers AND bolt carrier ass'ys (BCA) and gas rings. Could be any of them but the educated guess is that it is the BCA since the gun functioned with a different BCA. Did the rifle function before you changed the gas rings? Why did you change the rings? Did you replace them with standard rings? Rings are installed one at a time from the rear of the bolt. Start one end of the ring into the groove in the bolt, hold that end in place and "screw" the rest of the ring onto the bolt. Imagine threading a key onto a standard split coil key ring. Assuming that you correctly replaced the rings with standard parts the next step is to pull out the BCA that came with the Armalite and make sure that the carrier key screws are tight. If they are then take the BCA apart and check to make sure that the hole in the carrier key goes all the way through and that there is a corresponding hole in the top of the bolt carrier body. [speeling]
Link Posted: 10/29/2003 2:19:43 PM EDT
Thanks tweak, I'll take the carrier aparts and see what is going on.I took the rings off when I was cleaning the bolt,put it back together and it went from bad to worse as far as functioning.I got some standard replacement rings thinking that I might have bent one of the originals.I switched two things to make sure it wasn't a gas problem with the upper. My RRA carrier doesn't like my Armalite lower. I'll post agaim if it doesn't work. Thanks again![:D]
Top Top