Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 5/21/2003 8:02:39 PM EDT
Has anyone experianced the bolt going halfway fwd, while the trigger is being held back and locking up? It's a rock river lower and their 2 stage trigger. I think the hammer is too long and catching the firing pin on the way back into battery. I swapped lower with a second flawless functioning RR lower and the problem followed the original one. While dry firing the bolt carrier will just stop abruptly 1/3 to 1/2 the distance of travel. Too weird.
Link Posted: 5/22/2003 5:00:39 PM EDT
Are you riding the charging handle forward or letting the bolt drop on it's own?
Link Posted: 5/22/2003 5:37:25 PM EDT
While manually cycling releasing the bolt at full rearward position, while holding the trigger back that lower will stop the bolt 1/2 way fwd. I swapped lowers and the problem follwed this particular RR lower. Maybe the hammer is too tall and catching the firing pin. While firing the bolt carrier goes rearward, ejects and picks up the next cartridge, then abruptly stops. The new round is loose, not quite in the chamber, but not jammed on anything. Rebel
Link Posted: 5/22/2003 6:19:27 PM EDT
Remove the upper,restrain the hammer so it can not slam forward. push the hammer hard into the cocked position, pull the trigger and hold it. The sear should be holding the hammer,release pressure on the hammer,but keep your hand over it. Release the trigger, the hammer should snap up against the trigger. If this is working right, you will probably have to change out the hammer and maybe the sear. Another thing you might check is the firing pin collar. If it has a large collar, you can turn it down or change to one with the small collar (ring). Maybe this will help
Link Posted: 5/23/2003 2:36:02 AM EDT
The hammer, disconnector, and sear are functioning correctly. Both bolt carriers are not shrouded, and that appears to make a difference. Rebel
Link Posted: 5/24/2003 5:33:39 PM EDT
i had the same problem. it was the firing pin collar being to large. the hammer would catch it every time. i ordered an ar15 one from bushmaster and it works great now.
Link Posted: 5/25/2003 4:47:59 AM EDT
Thanks. I'll try a new firing pin. Rebel
Link Posted: 5/25/2003 5:44:33 AM EDT
make sure you order one for an ar15 not m16, the m16 have the large collar. the complete ar15 bolt and carrier group i bought had the m16 large collar firing pin installed, it really bummed me out when the hammer would catch on that wrong firing pin that came with it. i know bushmaster has the right one, but shipping costs more than the pin, oh well, i had to have it, i just ordered extras to make it worth it. extra firing pin retaining pins, cam pin, gas rings. the usual wear items.
Link Posted: 5/25/2003 6:54:10 AM EDT
Rebel Had exactly the same problem with a RRA. I had a RRA 16" A2 and decided to order a flat top upper. Received it and it functined correctly when mated to my existing lower. Decided that both uppers needed to be complete so I order a RRA lower and the NM 2stage trigger. Mated the new lower to the flat top upper and experienced exactly the same problem. Press the trigger, weapon discharges, and as long as the trigger is held back the bolt hangs up 1/2 way forward similar to a disconnector failing to capture the hammer and locking up the bolt. Called RRA and they were no help. Said they had never heard of the problem, suggested I had installed the 2 stage trigger incorrectly. Although I have installed several of their triggers I pulled the fcg and reinstalled. Same problem. Knowing the upper worked on the old lower I switched the uppers and both weapons function properly. I have several other ar's so i tried several combinations and all will function except the combintation of the new lower and flat top upper. I put the flat top back on the older RRA upper, moved teh A2 to the new RRA lower and everything working fine. Don't know if this helps but if you have the oppurtunity try switching uppers and loweres with another ar. DanS
Link Posted: 5/25/2003 7:27:49 AM EDT
Dan, I swapped lowers and the problem moved with it yet, it most even more prominent. I have a couple more uppers; I'll swap firing pins and see if there is a combination that works. Thanks to all that replied. Dean
Link Posted: 5/25/2003 7:28:53 AM EDT
Little FYI: If you check the firing pin stop edge on the carrier, you can see the amount that the edge hangs over the rounded back edge. If you mic the distance, then chuck the firing pin up in a drill and spin file the retaining lip down to be flush with the carrier lip, it will save you from having to order a new firing pin. Just lightly press the file to the rim, or you stand a chance of bending the firing pin. Or you can just roll file the hammer edge, where it is binding on the firing pin, to solve the problem. Reducing the firing pin collar is the easiest way to go, plus if the disconnector does let the hammer slip off, the hammer will still be caught in between the firing pin and the back of the carrier. As the carrier bolt move forward, the firing pin will be against the cotter pin with a gap in between it and the carrier. This gap is where the hammer will be retained, and prevent hammer follow threw.
Link Posted: 5/25/2003 9:17:52 AM EDT
Also had the exact same problem, firing pin collar was to big.
Link Posted: 5/25/2003 9:54:34 AM EDT
Rebel: After reading various other replys, I did the following. Got out the two RRA carbines I described earlier. Reassembled the upper and lower combination I experienced the same difficulty with. After dry firing, I held the trigger back and cycle the charging handle. The bolt carrier cycles all the way back and then moves only slightly forward. When I release the trigger the carrier returns to battery. I then took the entire bolt, firing pin, and carrier from the other upper and installed it. Weapon cycles correctly. I beleive this clearly indicates MY problem is somewhere in the bolt/carrier/firing pin assembly as it interfaces with the hammer. I next removed the firing pin and bolt which functioned and placed it in the carrier which did not. Weapon will not cycle properly. Since this carrier will function in the other RRA carbine, I am not sure if the carrier, hammer, or lower is slightly out of spec. I did not have the time today to start moving fcg's from one lower to the other. If it were me. since you have other ar's I would try another complete bolt/carrier/firing pin assembly prior to modifying existing parts. If the weapon still does not cycle you may need to look at the fcg or lower dimensions. Also, you might try moving a functioning upper to the lower you are having trouble with. At a minimum you should be able to determine if it is in fact the firing pin before you start grinding. DanS
Top Top