Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
Posted: 5/11/2003 10:21:10 AM EDT
Well I think the problems are due to mags and bad ammo. I just bought the Colt a few days ago and went to the range today. I had tons of failure to feeds/fires/jams/and trigger problems.

I did not use the factory 9rd mag (who wants to!) but two 30 rd GI mags and a 20 rd mag. The bolt failed to stay open on last round, it failed to load the next round into the chamber. Are these mag problems and not the rifle itself????

Also I was using the Olympic ss109 (made in Greece) ammo. The primers were blasting off the shells and jamming the chamber and trigger area. At one point I tried to load a round into the chamber only to find out the hammer would not drop! I unload and make safe. I open her up and behold 14 primers are jammed in the trigger mech. !!! It was tough getting all those things out!

Has anyone had problems with Olympic ammo 62gr ss109??? I tried a box of 55gr Winchester with NO problems (not even feeding) but that was only 25 rounds.

Any comments????
Link Posted: 5/11/2003 12:30:32 PM EDT
I had the EXACT same problem w/ one battle pak of South African! It was w/ my Bushy Mforgery and drove me almost nuts at the range that day. A blown out primer got lodge in the trigger group and was seizing everything up on me. Not much in the way of help but at least you know another person knows what you went thru ;) Rob
Link Posted: 5/11/2003 12:54:20 PM EDT
[Last Edit: 5/11/2003 12:56:37 PM EDT by M4WU]
It was crazy, I mean last year I had a Bushy dissapator and the thing jammed a few times with GI mags but not as much as what happened to me today!!! I understand since the pre-ban mags are not made to exact specs of each gun there is possibility of feeding probs and the such but I just felt like my Colt couldn't feed anything! Its brand new. I guess I just have to buy some more GI mags and do the "trail by error" until I find one that works Anyone else with the same probs? [edit] someone suggested *maybe* the gas port needs to be adjusted. This can only be done by Colt I guess since its in the front sight. Is this true?
Link Posted: 5/11/2003 1:36:57 PM EDT
[Last Edit: 5/11/2003 1:52:27 PM EDT by gregw45]
Originally Posted By M4WU: Its brand new.
View Quote
Try the 9 round mags. Mine are 100% reliable and will give you an idea if it's the rifle's problem or the 20 & 30 round magazines you're using. Don't dick with the gas port! Ditch the crappy ammo. ;-)
Link Posted: 5/12/2003 5:07:20 PM EDT
If you are popping primers, chances are you are dealing with crappy ammo. Olympic ammo has a pretty bad rep as far as quality goes [url]http://www.ar15.com/forums/topic.html?b=3&f=16&t=149562[/url]. I would suspect if you change your ammo, everthing will be fine. If it were the mags, most likely weak springs would cause your problems, but I really think it is the ammo.
Top Top