Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 1/27/2006 2:24:26 PM EDT
I installed my LT 9" today and it seemed a little odd;

Lining up the hole for the gas tube was a bit off, To line it up it seemed that the barrel nut wasnt tightened enough, I tried to go to the next hole on the barrel nut but It was going to take a lot of torque to get it there so I left it...Its not loose, just doesnt seem near 30lbs of torque as suggested. Anyone else experience this, and should I torque the sucker really hard to get it to that Next alignment?
Link Posted: 1/27/2006 3:45:44 PM EDT
Apply moly lube to the barrel nut threads if you have not done so. Tighten and loosen the nut multiple times. This will help you achieve an alignment at a lower torque value. Torque to 30#. If a hole does not line up for the gas tube, tighten until it does.
Link Posted: 1/28/2006 12:33:56 AM EDT

Originally Posted By M4Madness:
Apply moly lube to the barrel nut threads if you have not done so. Tighten and loosen the nut multiple times. This will help you achieve an alignment at a lower torque value. Torque to 30#. If a hole does not line up for the gas tube, tighten until it does.




+1
Link Posted: 1/28/2006 6:58:13 AM EDT

Originally Posted By M4Madness:
Apply moly lube to the barrel nut threads if you have not done so. Tighten and loosen the nut multiple times. This will help you achieve an alignment at a lower torque value. Torque to 30#. If a hole does not line up for the gas tube, tighten until it does.


+1 again
Top Top