Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 1/7/2006 1:49:05 PM EDT
This is my first build. I'm using a BM stripped lower and build kit so in theory the parts should all fit together nicely. To the pt where I attempted to install the trigger and disconnector that was true. However, the holes in the trigger and disconnector arent even close. I fiddled w/ them for a while and have concluded that there's no way to align trigger and disconnector so that the holes will line up enough for the pin to pass thru. In fact the closest I can get them is still way off in terms of metalworking tolerances. I do have an old Armalite trigger and the groove down the middle seems a bit deeper than the one in the BM. I can install the Armalite trigger just fine w/ a spare disconnector and the one that came in the BM build kit. Initally I figured that Id just go w/ the Armalite trigger and be done with it. However, when I install the hammer I cant get the safety in (being blocked by the trigger. I remove the hammer and the safety goes in but the hammer/receiver holes no longer line up.

So, now Im left w/ trying to figure out whats next. I dont want to modify parts as Im not completely certain how that will effect parts interaction. In short I could use some help....thanx AP
Link Posted: 1/7/2006 1:55:17 PM EDT
[Last Edit: 1/7/2006 1:55:51 PM EDT by M4Madness]
If you have the disconnector spring installed correctly (big end down) and the pin still won't go through the disconnector and trigger, then I guess it is a correct assumption that the tolerances are off.

As for installing the selector, cock the hammer first and it will go right in.
Link Posted: 1/7/2006 2:25:05 PM EDT
[Last Edit: 1/7/2006 7:25:51 PM EDT by AssaultPossum]
Thanx!! Let me give that a go.

ETA: That was it...I had the small spring in the trigger upside down.
Top Top