Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 10/24/2003 7:20:51 PM EDT
Unless I'm tring to put the wrong detent in the wrong place, the Model1 selector detent doesn't seem to fit my RRA lower.

Detent in question seems to be yellow zinc plated. It is pointed at one end, and has a groove and a raised ring at the other end. Length is 0.384" long, small diameter is 0.125", larger diamter is 0.146".

Funny thing is, when I turned the detent around, it went in just about as far as when I tried it pointy end first.

Is there some trick to putting it in? Wrong detent? Out of spec part or hole?
Link Posted: 10/24/2003 7:25:27 PM EDT
Not sure if you've seen this, hope it helps: [url]http://www.ar15.com/content/docs/assembly/lower/#selector[/url]
Link Posted: 10/24/2003 7:43:07 PM EDT
Nope. That was no help at all. [:P] I had a copy handy as I was putting the lower together. I couldn't get past, "Install detent."
Link Posted: 10/24/2003 7:49:05 PM EDT
The large part of that hole should be .188" deep and .156" diameter. Maybe it didn't get drilled deep enough for some reason. You might even make sure the .125 hole is clear all of the way through.
Link Posted: 10/25/2003 7:25:50 AM EDT
I had the same issue on my RRA lower and olympic arms kit. I did a search on the forum and found my answer. Put the detent pin in your drill and sand or file it down until it fits. Perhaps RRA is out of spec?
Link Posted: 10/25/2003 7:33:50 AM EDT
Suburban, Ditto what Stickerman said, perhaps the hole is not to spec. The reason for the stepped hole and stepped pin is to retain the detent in place when removing the safety selector, without having to remove the pistol grip (and spring, detent combo). If you modify the detent O.D. to fit, you might lose the captive detent feature. Harry
Link Posted: 10/25/2003 8:42:59 AM EDT
I had a similar prob with my RRA lower and RRA lower parts kit. The detent went in but was so tight you couldn't move the selector or get the detent back out! When I finally got it out, I spun a drill bit, by hand, in the channel to remove any burrs. Worked great detent went back in and selector moves fine now. Something to try anyway. Hershey
Link Posted: 10/25/2003 3:57:19 PM EDT
[Last Edit: 10/25/2003 3:59:26 PM EDT by Suburban]
Turned the detent down with a drill and set of honing stones. I just have to be sure to keep it oiled, since I've now removed the rust preventing zinc plating. My AR (er, LAR) is now fully functional. [:D] It seems that the hole in the RRA lower was too small. I'll send them an e-mail with a link to the thread. EDIT: Did not touch the raised ring, since the counterbore was properly sized. It was the smaller part of the hole that was too small.
Top Top