Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 1/12/2006 12:34:00 PM EDT
[Last Edit: 1/24/2006 2:16:50 PM EDT by 223Rem]


Changing a few rifle around and I if I had not removed the Aimpoint 3x Magnifier from one of my rifles, I would have never noticed it.

Not the best pic, but you can clearly see the crack goes cross the entire lens. At the ends of crack the lens has chipped.

No idea how long it has been that way because the damn thing still works! Amazing.....? Not saying I will not return it to Aimpoint and see if they can do something about it. This is mye first real world expereince of having gear severely damaged yet still functions. Nice to know.

Wonder if the EOTech magnifier can say the same?
Link Posted: 1/12/2006 12:41:18 PM EDT
Ouuuuuch!!!!

Damn man
Link Posted: 1/12/2006 12:48:48 PM EDT
wow, that's bad. Maybe they can do something for you. Can't hurt to try.
Link Posted: 1/12/2006 12:51:19 PM EDT
And that's with the rubber armor
Link Posted: 1/12/2006 6:18:57 PM EDT
Link Posted: 1/12/2006 6:23:50 PM EDT
When you say "It still works", do you mean you have used it and didn't notice the crack?
Link Posted: 1/12/2006 8:44:46 PM EDT
I guess when shooting on crack...how could you not notice that???
Link Posted: 1/12/2006 10:07:50 PM EDT
The picture is not clear enough, but it seems that crack started on both sides under the rings. I would guesstimate that it is the resoult of overtightening the ring (factory error). Call them, i am sure they will fix it.
Goodluck.
Link Posted: 1/12/2006 10:25:10 PM EDT
Link Posted: 1/13/2006 6:16:52 AM EDT

Originally Posted By Matt_B:
When you say "It still works", do you mean you have used it and didn't notice the crack?



Not sure when it cracked, but the rifle it was mount has not been used lately. I mounted it behind my Aimpoint and EOTech and it appears to be working.

Have not had a chance to contact Aimpoint yet as most of my time lately has been spent caring for my mom
Link Posted: 1/13/2006 7:18:40 PM EDT
[Last Edit: 1/13/2006 7:19:55 PM EDT by avslash]
I'm curious if you removed the rubber armor around the ring mounting surface before tightening it down. I was looking at a 3xMag for my govt. carbine at a local shop yesterday and the resident AR guy told me that Aimpoint recomends just that as the tube is oversized unless you are using their mount. Wondering if a too tight ring might have been the problem. Sounded fishy to me at the time that a manufacturer would recomend butchering their product.

I thnk I'll start a thread to see how people running the 3xmag have them mounted.
Link Posted: 1/20/2006 7:22:49 AM EDT
Well, the magnifier is off to Aimpoint. The representative I have been dealing with has been extremely helpful. We shall see.......
Link Posted: 1/20/2006 9:33:59 AM EDT
Link Posted: 1/20/2006 9:43:38 AM EDT
It sure looks like equal pressure from two sides.... If nothing else, this is a good learning experience for other people.
Link Posted: 1/24/2006 2:15:03 PM EDT

Originally Posted By Stickman:
It sure looks like equal pressure from two sides.... If nothing else, this is a good learning experience for other people.



As for me, this has not only been a learning expereince but an experience dealing with a great Customer Service Rep and a company that stands behind their gear.

I shipped Aimpoint the unit on Wednesday and today I received a brand new unit! No Charge, except for the engineers at Aimpoint are probably shaking their heads and calling me a asshat, but I can live with that.

Off to EE to find an Aimpoint Twist Mount.........
Link Posted: 1/24/2006 2:33:40 PM EDT
Outstanding! I'm glad you were well taken care of.
Top Top