Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 11/11/2003 2:19:06 PM EDT
[Last Edit: 11/12/2003 12:53:24 PM EDT by Mordak_1]
I have one 30 round mag that causes a bolt over jam on the 5th, 6th, and 7th round out of the mag. It feeds correctly on all other rounds. Has anyone else had this problem? does this sound like a follower issue?. I have another mag that does the same thing with the last 2 and I have read here that that IS a follower problem. I am getting all new green followers for my 30 rounders to see if it cures both problems. I am using a Bushmaster A2 20" and USGI mags. All of my mags currently have black followers and are in good condition.
Link Posted: 11/23/2003 9:49:03 PM EDT
If that is the only Mag I would first try to put a green follower in it. If that does not work then I would shoot the bastard and be done with it.
Link Posted: 11/23/2003 10:23:26 PM EDT
Mordak_1, Is the magazine spring properly installed on the follower?
Link Posted: 11/24/2003 6:32:45 AM EDT
I have replaced the black follower with a green follower and it no longer jams when I test feed. I havnt had time to do a real firing test yet. Yes the spring is installed on the follower correctly. I'll let you know if this fixes it when I get a chance to shoot. Thanks.
Link Posted: 11/24/2003 2:41:16 PM EDT
Link Posted: 11/24/2003 3:03:51 PM EDT
I check every mag before I buy it for tight spots in mag body. This mag is a little bit more snug that my others but not enough to grap and hold the follower. I did run the follower down several times right after I installed it. And before the question come up, I got my green followers from Magazine Specialties.
Top Top