Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 5/4/2003 4:54:28 PM EDT
anyone have any probs with these? i have two and when i first tried one fully loaded, i couldnt get the mag to catch...i took some rnds out..about 10 to be exact...it caught but the would contantlty jam...the both did the same. anyone else have this issue?thanks
Link Posted: 5/4/2003 6:09:59 PM EDT
Of the two I tried, the springs do appear to be a bit stiff. I don't have any problems when I open the bolt first.
Link Posted: 5/5/2003 7:45:21 AM EDT
First, take a ruler and work the follower on an empty mag 30 times. Second, if you still need to, use a small file to clean up the mag catch hole on the mag. Chances are, you'll find that the hole is not square and perhaps slighly too far forward.
Link Posted: 5/5/2003 8:05:32 AM EDT
Did you try inserting the full mag on a closed or open bolt? The only trouble I have had with mine was the bolt not staying open after the last round. Changed them to a green follower and now they work fine.
Link Posted: 5/5/2003 6:13:51 PM EDT
I purchased 20 of the no-name "England" mags and had to trim the center leg of the dark blue follower by about 0.1" in order for them to match the USGI black and green follower legs. After trimming, a full 30 would insert fine and lock easily without filing the mag catch hole. After trimming, the English mags would still only hold 30 rounds. Noah
Link Posted: 5/5/2003 7:25:16 PM EDT
i never did try to insert the mag with the bolt ope...ill try that tommorow and hope it works a little better
Top Top