Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 2/2/2006 12:29:54 PM EDT
[Last Edit: 2/9/2006 5:59:40 PM EDT by m499]
I have a RRA 9mm upper with a 9mm buffer, Hahn bottom loading block and Colt 20rd mags.

At first I thought I was having trouble with the mags because I was getting alot of failures but after thinking about it a bit... duh... it seems more like an ejector or extractor problem. The empty brass case is extracting fully from the chamber and a new round is loading properly but the empty case is not clearing the action or exiting via the port door. Apparently its just bouncing around in there until it binds up with the bolt and screws everything up. I'm getting 3-4 of these "failures to eject"? per mag. Can anyone help me out with suggestions on how to get this thing running again.

Thanks all
Link Posted: 2/2/2006 5:28:08 PM EDT
If you are also using a RRA bolt, do check the extractor pin. Make sure the pin did not walk out of the place to the point that it's no long holding the extractor in place. This will allow the extractor to slide forward during the extraction cycle letting go of the brass before it contacts the ejector thus causing a jam.

I had the same fail-to-eject problem until I got the extractor roll pin replaced.
Link Posted: 2/2/2006 6:27:48 PM EDT
Unless ejectors are damaged they will always work......DO NOT tweak ejectors on the Hahn blocks as they are designed to float thier way thru the carrier slot to compensate for variation and least amount of friction.

Orange Neck is correct about the extractor........seems to be a problem with shitty pins holding extractors in place......it is also possible your extractor is weak.......although less likely.
Link Posted: 2/3/2006 2:56:14 AM EDT

Originally Posted By Dehammer:
DO NOT tweak ejectors on the Hahn blocks as they are designed to float thier way thru the carrier slot to compensate for variation and least amount of friction.


+1
Top Top