Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
Posted: 12/15/2005 9:53:34 AM EDT
[Last Edit: 12/30/2005 6:39:43 AM EDT by dusman]
remove please
Link Posted: 12/15/2005 9:59:36 AM EDT
You might have it on wrong. Mine fits securely. Make sure you have the hook on the barrel nut correctly and tighten the allen screw. Make sure you don't over tighten the screw.
Link Posted: 12/15/2005 12:08:27 PM EDT
[Last Edit: 12/15/2005 12:09:40 PM EDT by m24shooter]
If you have it installed right there shouldn't be any losseness. The barrel nut gas tube slots should rest in the two reference pins and the clamp should pull it tight.
Is the whole thing loose or jsut the bottom?
ETA:
Might want to post over in the Accessory threads. ColdBlue watches for KAC posts and will help you out if there is any way possilbe on Earth. He works for KAC and is a big part of their excellent CS rep.
Link Posted: 12/15/2005 12:22:25 PM EDT
Only the bottom is loose.I appreciate all the help.
Link Posted: 12/15/2005 12:29:06 PM EDT
Alright then, you might have an abused bottom unit. That sounded kind fo dirty didn't it?
Anyway, did you buy it new or used?
There is an SAS bottom unit for the M4 systems that clamps like the upper, and they might make one for the M5, but I don't really know. Might want to look at their website.
Otherwise, it is not unusual to have some fore and aft movement in the bottom piece. That's part of why you don't see OTALs and such mounted down there. It's mainly for the VFG or lights, and it doesn't really matter if those shift around some.
Top Top