Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 12/16/2003 10:09:05 PM EDT
I was at the range today firing a 16" bushy m4, using five , 30 rd sa80 mags and L.C. XM193. Every second round or so, the bolt carrier would either catch on the first round as it drove home, or it simply wouldn't slam into battery. The rifle was as clean as a whistle and oiled. Do these mags usually sit slightly higher in the well? thanks, vt
Link Posted: 12/17/2003 3:37:23 AM EDT
A friend of mine just bought 3 of these mags and one of them sat so high that it wouldn't lock into the lower. He hasn't tried them yet, so I can't tell you if he had feeding problems with them.
Link Posted: 12/17/2003 7:56:41 AM EDT
you can try (carefully) filing the mag catch slot in the magazines to allow them to sit slightly lower.
Link Posted: 12/17/2003 8:17:00 AM EDT
I purchased 7 of the SA-80 mags from TAPCO. All 7 work perfect in my Colt..
Link Posted: 12/17/2003 8:41:23 AM EDT
It seems to be a really mixed bag w/these mags. One guy will tell you his were fine from the jump, while the next one will inform you that the mag slots need to be filed. I can only assume that it all depends on what lot or batch you got your mags from. My own 4 all needed the mag slot opened up to function properly; and it sounds like yours do too. Not a big deal, and it doesn't take much filing to get them right.
Link Posted: 12/17/2003 2:39:13 PM EDT
I got six of them when Dans had a sale, and two of them needed filing (just a tad) and the rest locked up perfectly. I have yet to have a problem with any of them, as far as function is concerned.
Top Top