Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 10/25/2003 1:01:05 PM EDT
Just got back from the range after installing a tele-stock on my Bushy carbine. This gun started out with a full A2-style stock and have never had a problem with it in that configuration. Now it is not functioning correctly. I think the cycling is thrown off because of the shorter buffer tube and spring. Is this common? I can't think of anything else it could be. Let me just say also that this is a very poor quality tele-stock from Tapco. It rattles like hell, but I didn't think that would affect the cycling. I don't plan on keeping this POS stock on there, but I would like to eventually put another carbine stock on there. Has anyone had a similar expwereince or can explain this problem? Thanks in advance...
Link Posted: 10/25/2003 1:18:22 PM EDT
You have not even attempted to describe your malfunction. How could we help you unless you tell us what your malfunction is?
Link Posted: 10/25/2003 1:29:05 PM EDT
I'm sorry. The bolt carrier/ bolt won't strip a round off the mag. It will only fire single shots and then I have to pull the charging handle back to load another round. That's why I said it seems to me that it's not cycling far enough back to catch another bullet.
Link Posted: 10/25/2003 1:34:08 PM EDT
also, prior to an ARFCOM diagnostic test, what ammo are you shooting?
Link Posted: 10/25/2003 1:43:41 PM EDT
I'm shooting Olympic brand brass-cased ammo out of it. I'm at the end of a 1,000 round case though and haven't had any FTF's or FTE's out of my other gun. This is the first time I've tried shooting it out of my Bushy. I'm tending to believe it's not the ammo. I can't see how that could be the problem here, but then again, I'm the one asking for advice here.
Link Posted: 10/25/2003 2:10:40 PM EDT
If it's a really cheap unit, and it came with a buffer, my first thought is that it may be one of the sleazeball buffers that I've seen w/other el cheapo telestocks. A properly contructed buffer will have steel weights alternating w/ thin rubberized discs, and you can feel the weights moving back and forth somewhat, when you shake the thing back and forth. Many of the el cheapos just have a bunch of lead shot in there for weight, but that totally screws up the recoil cycle of the action. That, combined with a POSSIBLE need for a heavier extractor spring, can really screw up the action cycle of a carbine type. See if you can borrow a Colt, Rock River or bushmaster buffer from someone, or just go ahead and spend the bucks for a good name brand buffer, and see if that doesn't help matters[:D] And yes, Olympic ammo doesn't have the best rep in the world, and might be contributing to the problem; tho I'd doubt it's the promary cause.
Link Posted: 10/25/2003 2:14:51 PM EDT
I've heard about this lead shot and bb stuff, but I don't think I have anything in there to counter the weight.
Link Posted: 10/25/2003 2:39:50 PM EDT
[Last Edit: 10/25/2003 2:46:39 PM EDT by MADM16A1]
You have a weak spring. buy a quality buffer and spring and you should be ok. Before you do that, manually push the buffer into the stock all the way in and look for any restrictions. Good luck!
Link Posted: 10/25/2003 3:49:52 PM EDT
[stoopidquestion]You ARE using a Carbine buffer right?[/stoopidquestion]...Sorry had to ask................UNDERDOG
Link Posted: 10/26/2003 2:20:04 PM EDT
Yes, it's a carbine buffer/ spring/ tube.
Top Top