Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 10/24/2003 4:24:42 PM EDT
On mine the latch button only returns about half way and never 'latches'. The grip stays in place pretty well, but shouldn't it latch firmly and require a push of the button to adjust the position of the grip? Mine will always move with enough pressure.
Link Posted: 10/24/2003 7:09:08 PM EDT
My Fobus vertical grip locks solidly in place, and the button comes all the way out (not out completely as in falling out, just out like it is when not on anything) when in the rail groove. I had to do some file work on mine to get it to work on the Picatinny rail of the USC, so check your locking latch to make sure it is not too wide for the groove. I think they are made a hair on the small side to allow for wear or use on Weaver rails. Getting it to fit the Picatinny was a bear.
Link Posted: 10/25/2003 4:54:54 AM EDT
Originally Posted By Big-Bore: My Fobus vertical grip locks solidly in place, and the button comes all the way out (not out completely as in falling out, just out like it is when not on anything) when in the rail groove. I had to do some file work on mine to get it to work on the Picatinny rail of the USC, so check your locking latch to make sure it is not too wide for the groove. I think they are made a hair on the small side to allow for wear or use on Weaver rails. Getting it to fit the Picatinny was a bear.
View Quote
Thanks BB... That's what I thought it should do.
Top Top