Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 7/7/2003 3:07:07 AM EDT
I went to the range yesterday with a newly installed RRA 2 stage NM trigger. Man what a difference!! My groups tightened up considerably at 100 and 200 yds. Still far from a single ragged hole however.

When I pulled the trigger back thru the first stage then released pressure because of gusty winds the trigger did not return to the starting position. Is this normal or do I need to make some adjustments? If adjustments are necessary what should I do? Thanks for any help.

Shabo
Link Posted: 7/7/2003 4:08:01 AM EDT
Something sounds like it is off a little. I have a few Hollinger tuned RRA NM triggers and they always return. First thing I would check is if the springs are laying correctly.
Link Posted: 7/7/2003 7:38:39 AM EDT
Sounds funky. Mine, if pulled for the length of the 1st stage, then let off, returns to the "starting point". One thing: Clean the surfaces well. Lightly oil them. ALWAYS clean your trigger! Grit and grime, when trapped in the oil, can lap your surfaces down...
Link Posted: 7/7/2003 11:48:27 AM EDT
Mine did the same exact thing when I first installed it. It disappeared after dry-cycling about 20-30 times. The way I do it is (making sure weapon is clear, first) charge the weapon, pull trigger, while holding trigger in rearward most position, charge the weapon again then repeat process. Worked like a charm.
Link Posted: 7/8/2003 2:07:45 AM EDT
Thanks for the responses guys. 2Manchu I tried the dry firing you suggested. Seemed to work real well, no more sticking. Thanks bro!! We'll see what happens at the range next time. Shabo
Top Top