Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 5/28/2003 11:32:47 PM EDT
Hi all,

I have installed an Accuracy Speaks trigger ass'y on my 20" bbl Oly and it's a wonder for a year but now that I fitted it on my new M4, something wrong happens. From time to time the rifle will fire 2 bursts.
Someone told me that the trigger is not a problem but rather the disconnector spring.
The M4 lower though second hand one had not fired more than 300 rounds if I believe the seller.

Any suggestions is appreciated.

LRRPS.
Link Posted: 5/29/2003 12:14:37 AM EDT
I think it might be the trigger, just a little too light of a pull. I have a RRA two-stage that did the same thing. When I got it replaced it repaired the problem. I know its not the same trigger but I used all the same springs, just swapped out the hammer & trigger assembly. I would at least call Accuracy speaks and talk to them about it. Prosise
Link Posted: 5/29/2003 1:32:32 PM EDT
Most likely it's firing once when you pull the trigger and again when you release it. If that's the case you need to adjust the disconnector. Call Accuracy Speaks and they should be able to walk you through it.
Link Posted: 5/30/2003 12:54:35 PM EDT
Not sure about Accuracy Speaks triggers, but I once had the same problem on my Compass Lake trigger. Compass Lake sent me a new disconnector spring and that took care of the problem. Don't discuss this problem very widely - the ATFE has been known to claim that such malfunctioning guns are machine guns.
Top Top