Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 11/18/2002 4:46:27 PM EDT
I tried to set my battle zero today at the range and had some problems. I set up at 50yrds and cracked 3 off with the factory sight setting. I barely hit paper. Had to adjust windage ALLL the way left to get close to center. It still is a good 4" off center. Talked to Oly abd they said send it in and they'll take care of it. Still curious though how high above center should I be hitting. I'm not used to the peep sight but as far as I can tell i'm sighting properly but I'm atleast 3" above center. I doubt I should still be that high. My grouping pretty much sucked but thats probably partly my shooting and using PMP ammo which I know isn't exactly all that great. Another problem i had was trying to put a scope on. I have an inexpensive handle mount, maybe the problem? But neither scope I tried to mount had enough adjustment in any direction to come close to being sighted in. Would this be bad carry handle or mount or both? Or am I using the wrong type of mount? Would a scout mount be the one i need? I tried a bushnell holosight and an old simmons red dot. All in all I'm not very impressed in the performance of the rifle. Had a friend give it a try again with disappointing results. we were shooting on a bench without a real rest. Any advice?

Link Posted: 11/19/2002 1:38:05 AM EDT
Seems like all companies have this problem every now and then. It is easily fixed by any manufacturer.
Link Posted: 11/19/2002 10:58:18 AM EDT
Send it back to Oly and have them make it right. Then shoot it some more and make your decision.
Top Top