Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
Posted: 1/29/2002 8:19:02 PM EDT
[Last Edit: 1/29/2002 8:27:47 PM EDT by Dragracer_Art]
Here's my problem... '94 Suburban K2500, 454/AT, Loaded... Truck has a zillion miles on it, and runs good with the exception of an annoying "BOG" when I jump on it... What I've noticed is, with a timing light attached, the timing will advance properly when I slowly bring up the RPM's but when I crack the throttle wide open or real quickly, the timing stays retarded and the motor bogs REAL bad... I've replaced the fuel filter, which made a BIG difference, the TPSensor, and the IAC Valve... All of which helped, but it's still not "right"... My guess is, it's either a p/u coil/timing related problem, or a fuel pump taking a crap... The fuel filter I took out was almost completely clogged...I tried blowing through it, with no success... If I had to take a guess, it almost seems like it's starving for fuel...regardless of the lazy timing issue... I was thinking of putting in an older mechanical advance distributor, and eliminating the computer controlled unit... Any ideas guys ???
Link Posted: 1/29/2002 8:26:37 PM EDT
Have you got a Mass Air Flow type of sensor in the airstream, somewhere in the fresh air intake? The Ford version has a couple of little lightbulb-style filaments that the air blows over, on its way to your intake manifold. When these filaments become "crapped up" with gunk, they give the computer bad data to run your engine with. Just de-gunk it with either electrical contact cleaner, or carburetor cleaner. Dirty sensors play havoc.
Link Posted: 1/29/2002 8:31:28 PM EDT
Nope, no MAF sensor, just a carburetor like TBI unit with 2 overhead injectors... Pretty simple system for someone with late model GM experience... I'm stuck in the older Chevy drag car stuff... Not up to date on the new technology...
Link Posted: 1/29/2002 8:40:05 PM EDT
Possibilities 1) Starting in '94, you cannot simply attach a timing light to check the timing. First you must dissable the electronic ignition. There should be a tan wire with a black stripe to the right of the heater box, under the dash (right above where the shotgun passenger would rest his feet). There is a conveniently located male/female connector. Disconnect it, then use your timing light. I don't know about the 454, but my 350 has to be set to 0 degrees BTDC...I would imagine the 454 would also be set at 0 degrees. 2)Changing the fuel filter shouldn't make any difference if it is changed every 30,000 mile like it should be. Since you got results from changing it, my guess is that it had been there for quite some time. This could have lead to excessive fouling of the injectors. 3) Fuel Delivery: While the severe hesitation could be do to timing, it can also be caused by low fuel pressure, as you suggested. The pump may be crapped out, but don't forget about the sending unit. There could be all sorts of junk caked up on the outside of the sending unit sock, obstructing the flow of gasoline. It wouldn't be a bad idea to replace the pump and the sending unit if the pump turns out to be the problem. Just pressure check the fuel delivery system, or take it somewhere to be tested. My bet is on number three if you correctly checked your timimg.
Link Posted: 1/29/2002 8:41:22 PM EDT
Sorry, guy. That is the symptom and the fix for my 94 Ford truck. Pull some of your plugs and look at them. Their appearance will tell you lots of stuff.
Link Posted: 1/29/2002 8:44:06 PM EDT
I guess injectors belong under fuel deliver don't they. Oh well, hope I helped a bit.
Link Posted: 1/29/2002 9:11:02 PM EDT
[Last Edit: 1/29/2002 9:18:42 PM EDT by Dragracer_Art]
Already did the battery disconnect thing when I replaced the TPS & IAC valve... Truck ran better after these, including the F/filter, were replaced... I'm thinking maybe the strainer in the fuel tank may be clogged, or the pump going bad... The frame mounted fuel filter was clogged almost completely... I had the timing light attached only to observe the advance curve, and not to reset it, so the tan wire stayed connected... Maybe flat, retarded timing under heavy acceleration is programmed into the computer to avoid tire frying pullouts from soccer practice??? Next time the tank is near empty, I'll drop it & replace the pump/sender/strainer assy... Next will be replacing the computer controlled distributor with an older mechanical advance distributor... This truck weighs nearly 6000 lbs, so I'm not expecting it to be a tire frying street machine... Just want it to run like a 454 again... Forgot to mention, I bought the truck real cheap, with 195,000 highway miles on it... Truck is built like a bulldozer, is in beautiful shape, and has great oil pressure yet... I went to the Chevy dealer that delivered it new, and got all the service records... Truck was WELL maintained, with exception to the fuel filter... I may end up rebuilding the motor in the spring just to "freshen" it up. Thanks for the ideas guys !!!
Link Posted: 1/30/2002 4:12:24 AM EDT
Don`t replace the distributor.....you`ll end up with worse headaches.....you`re headed in the right direction......you can also get a tbi kit...which will give you new gaskets...especially the base gasket which often suffers from heat and drying out......you can get the injectors cleaned out...they usually don`t go bad on those tbi units......just make sure the dist shaft doesn`t have excessive wear.....make sure the module connection/ plug is clean and not green...and yes...the timing.....but not the old conventional way.....(start by timing by ear)...you must have done that before.......majority of these chevy truck problems are right there in the gas tank.........assume that you already eliminated ANY vacuum leak????.........
Link Posted: 1/30/2002 7:04:45 AM EDT
Originally Posted By BlackandGreen: Don`t replace the distributor.....you`ll end up with worse headaches.....you`re headed in the right direction......you can also get a tbi kit...which will give you new gaskets...especially the base gasket which often suffers from heat and drying out......you can get the injectors cleaned out...they usually don`t go bad on those tbi units......just make sure the dist shaft doesn`t have excessive wear.....make sure the module connection/ plug is clean and not green...and yes...the timing.....but not the old conventional way.....(start by timing by ear)...you must have done that before.......majority of these chevy truck problems are right there in the gas tank.........assume that you already eliminated ANY vacuum leak????.........
View Quote
Already went over the vacuum lines...some have been previously replaced... Timing is steady, and not "erratic", so I think the dist shaft/bushings are "ok"... I haven't had the 2 injectors apart yet... The fuel is spraying in a nice atomized pattern, so I didn't bother fooling with them... Seems I completely overlooked the strainer in the fuel tank... Unfortunatly, I just filled the 40 gallon tank a few days ago... Won't be able to drop it right away... The 454 will have no problem emptying it in short order though... I'll post a progress report when I do finally drop the tank...
Top Top