Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 4/7/2006 11:03:15 AM EDT
My RRA two stage was acting like a single stage after my last trip to the range. I figured that it was just because it was super dirty as I had'nt cleaned it for a while. I cleaned it like I usually do last night and it is the same. Is this a common problem with a simple fix or am I up shit creek?

Any help will be greatly appreciated.

Thanks.
Link Posted: 4/7/2006 11:07:06 AM EDT
take it out of the lower and scrub it clean. I bet you will find a bit of primer or some junk that is dinking it up.

Link Posted: 4/7/2006 11:07:33 AM EDT
shouldn't this be in the ar15 forum

sorry, but I don't have a clue how to fix your problem
Link Posted: 4/7/2006 11:11:52 AM EDT
This is a common problem. You're not the first.
Link Posted: 4/7/2006 2:38:48 PM EDT
This was in the AR troubleshooting forum and I got no answer. I find that general discussion gets way more traffic and I figured that with a question such as this the odds of someone having an answer were quite high. I always eventually end up moving my questions to GD just for lack of feedback in the tech forums.
Link Posted: 4/7/2006 4:01:28 PM EDT
I've heard that before about RRA triggers but have no first hand experience. For the life of me I can't figure our why someone doesn't make a plain jane 2 stage trigger like the one in the M16. It doesn't have to be match, just service grade and at a service grade price.

jd1
Link Posted: 4/7/2006 4:11:17 PM EDT
[Last Edit: 4/7/2006 4:12:55 PM EDT by eodtech2000]
If you can't get it solved, send the trigger to John Holliger at White Oak Armament , he will get into shape for about $30, he is one of the top ar-15 smiths in the country and nice guy to boot.White Oak


ETA: I have a RRA two stage trigger that has been worked over by White Oak, it is very nice and they set the break at 3.5 lbs.
Top Top