Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 12/19/2003 11:19:04 PM EDT
Okay, I flushed and the water kept running. It's not clogged, and it wasn't overflowing. It was a little above normal and water was still pumping in though. I waited a while and it was still doing it. So, I wiggled the handle a little bit to see if it would quit. Nope, kept going. I flushed...nope, it started to make the water rise a little bit though. Then all of a sudden the tank started to over flow...I turned the water off and pulled of the lid. Everything looks fine...what should I look for???
Link Posted: 12/19/2003 11:29:17 PM EDT
If the tank kept filling until it overflowed, your float/fill device needs replaced.
Link Posted: 12/19/2003 11:42:50 PM EDT
You need to replace the little seals inside mechanism where the float connects. Any of the home repair places should have the parts.
Link Posted: 12/19/2003 11:44:24 PM EDT
Okay, I looked at it again and there is a little tube that goes from the floater thing to a pipe that is connected to the door thing on the bottom...ya I am descriptive...anyway, that tube wasnt in that pipe and it looked like there was a notch for it...so I stuck it in. It fixed it. I dunno if it was just coincidence but it works and my bathroom didnt flood... Thanks
Link Posted: 12/20/2003 1:58:54 AM EDT
Sounds like you also had the water turned on a little too high. When it over fills it should run out the pipe fast enough to keep from overflowing the tank. As noted the float should have stopped it. But if the tube came out of the bracket it might have been holding the float down at the same time. It's pretty hard to break one and they are easy to fix.
Top Top