Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
Posted: 6/15/2002 6:41:41 PM EDT
I just got through changing the timing belt on my ranger and it sounds like it wants to eat itself when you rev the engine. It idles perfectly, but when you give it the gas it sounds like it is pinging or contacting valves to piston...I think that is unlikely considering that it didn't quit running. I need to here what you think.
Link Posted: 6/15/2002 6:57:35 PM EDT
Oh come on now, somebody out there has got to be a Ford tech.
Link Posted: 6/15/2002 7:04:15 PM EDT
i am not a mechanic, but did you check the timing, with a timing light.
Link Posted: 6/15/2002 7:04:44 PM EDT
I'd suggest you check your work. Not familiar with the not mentioned engine, but the distributor/pickup for timing the spark is often run off the end of the cam. If you have your cam timing off a tooth or two advanced the engine might run ok at idle but detonate at open throttle positions
Link Posted: 6/15/2002 7:09:29 PM EDT
What engine do you have? 2.0/2.3? If so, this is not an "interferance engine, meaning if you strip the belt the valves will contact the piston. However it is possible if the RPM is really high. If the valves contacted the piston it would not have any compression, and would not have restarted. I think you missed the timing marks on the jack shaft, and now your timing is too far advanced giving you spark knock. Check your belt setup again.
Link Posted: 6/15/2002 7:16:23 PM EDT
I've got the 2.3, it's a '97 2WD with the A.C. So, contrary to what I've heard it's not an interferance motor...that's refreshing to hear. Sorry for the lack of details before.
Link Posted: 6/15/2002 7:21:48 PM EDT
recheck the tension on the belt, if a timing belt is too tight it will make the noise you are describing.
Link Posted: 6/15/2002 8:45:43 PM EDT
did you put the distributer 180 degrees out when you put it back in? I would agree, recheck your timing and make sure your timing gears were installed correctly.
Link Posted: 6/15/2002 9:26:07 PM EDT
You are probably a tooth or two off. It sucks, to have to do it, but I recommend you double check your work.
Link Posted: 6/15/2002 9:46:21 PM EDT
Ford Senior Master Technician here! First off, if the timing belt were off a tooth or two, the engine will run but be a REAL pooch, slow to rev and lacking power. A 2.3L in a 97 Ranger is a DIS system, so there is NO distributor to contend with. My guess is that the belt tension is too loose or, there is something making contact with the timing belt. There is a crankshaft position sensor behind the lower pulley that may be contacting the trigger window or the belt may be contacting the timing belt cover itself. Remember, this is a free spinning engine, there is no possible way for the valves to contact the pistons, if the T-Belt breaks at 6000 RPM, there will be NO piston to valve interference.
Link Posted: 6/15/2002 10:18:00 PM EDT
[Last Edit: 6/15/2002 10:19:29 PM EDT by oneshot1kill]
Link Posted: 6/15/2002 10:32:55 PM EDT
Originally Posted By NHRAMark: Ford Senior Master Technician here!
View Quote
Why does the ranger I have make a knocking sound, kinda like dieseling, during acceleration after it has warmed up? I tried changing gas and even used ZMAX and STP engine cleaner gas additive, but nothing happened.
Link Posted: 6/16/2002 8:11:24 AM EDT
Whats up mark, im a ford tech too, Imbroglio, if yours is a 98-00 3liter, there is a New processor wiht a different calibration and a new coilpack that works well in fixing spark knock. Post your vin and i will see if its applicable.
Top Top