Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
Posted: 3/14/2006 8:20:45 AM EDT
I have a laptop I use (issued) at work. It used to work great with the network. I am comfortable working on/around computer, but I am not knowledgable in how our newtwork operates.

Needless to say I can still access the internet, but I cannot access the servers. I have a Panasonic Toughbook with Windows XP Pro. After sitting down with the IT guy we find my computer can "ping" the server and other PCs by their address, but not name. This seems to be a problem. We feel my Laptop may have to be reformatted. I have used a PC to PC Cat 5 cable to transfer my files (about 10 gig) to another laptop. My laptop could not view the other laptop files. BUT the other laptop could view my files and did the transfer from the second laptop.

My question is: Am I missing something here such as a setting or is this a classic sign of a virus/spyware? Any and all help would be appreciated.

Thanks in Advance,

Mike
Link Posted: 3/14/2006 8:35:55 AM EDT
[Last Edit: 3/14/2006 8:38:52 AM EDT by JAKE-T-SNAKE]
Look for a program called winsockxpfix.exe winsock xp fix run it and it will restore many strange network errors caused by viruses and/or malware.


Here
Link Posted: 3/14/2006 1:34:28 PM EDT
Link Posted: 3/15/2006 4:22:53 AM EDT
Thanks for the replies so far. I have tried winsockxpfix.exe, which was initially given to me by the IT guy here. I tried the link above and downloaded that one. It seemed to take things a step further and wiped my IP, DNS, etc out. Which tells me something else maybe reset so I am in the process of getting those addresses back.

I also learned my Laptop is no the only one having this problem so it maybe another internal setting. I appreciate the help so far.

Thank you,

Mike
Link Posted: 3/15/2006 5:04:06 AM EDT
[Last Edit: 3/15/2006 5:05:26 AM EDT by cruze5]
it sounds like a software firewall to be honest

what antivirus are you running, what firewall are you running other than xp built in firewall.

if you are running norton internet security. or mcafee firewall. even if you allow a range of allowable ip address settings, i have still seen that software block network access. If your running one of those i suggest unintalling to see if it fixes the problem.

could try sfc /scannow........ could try to reintall sp2(i mean just the service pack). could try installing a secondary nic.

i think tweakui, and other programs will tinker with network settings, so i would suggest going through those programs and if need be unistall those.


you can reinstall the tcp/ip

netsh winsock reset

and then posted from microsoft. link

15. In Control Panel, double-click Network Connections, right-click Local Area Connection, and then select Properties.
16. On the General tab, click Install, select Protocol, and then click Add.
17. In the Select Network Protocols window, click Have Disk.
18. In the Copy manufacturer's files from: text box, type c:\windows\inf, and then click OK.
19. Select Internet Protocol (TCP/IP), and then click OK.

Note This step will return you to the Local Area Connection Properties screen, but now the Uninstall button is available.
20. Select Internet Protocol (TCP/IP), click Uninstall, and then click Yes.
Link Posted: 3/15/2006 11:20:17 AM EDT
I got it to work finally. Thank you everyone. All the replies had a little help letting me know I was headed in the right direction.

I found the WINS had no setting. Also found I needed to enable the TC/IP fltering. I also found some setting the internet explorer had been changed. I can read the IP and name addresses of the other computers in the network.

I also tried to set up the laptop of another co-worker today as well. I still had to use IP addresses to map the network drive, but everything works. I will have to look at it again another day to finish it.

Again I appreciate everyone's help.

Mike
Link Posted: 3/15/2006 11:33:24 AM EDT
What you are describing is a NAME RESOLUTION problem.

When everyone is using a MS OS that supports broadcasting, and everyone is on the same subnet, then small workgroups used broadcasting to find the NetBIOS name/address.

However, WINS entered the picture for larger and more complex networks. Somewhere on your network, you *should* have a WINS server, and that WINS server must be configured on everyones workstation in order to resolve names. Your IT guy should be shot if he didnt check this first thing. The easiset way to control this, is to use DHCP on the network, so all clients get their IP, WINS, DNS, etc... information automatically.

Nowadays, WINS isnt necessary, IF you have Windows 2000+ active directory and Dynamic DNS. I still recommend WINS for small companies - it creates zero overhead and works with all Windows clients.
Top Top