Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
Posted: 3/11/2006 6:58:47 PM EDT
[Last Edit: 3/12/2006 6:49:57 PM EDT by mace]
I've been having a pretty strange problem here. Any fellow geeks have any ideas? We just bought a NetGear wireless router to replace an AirPort Express base station (looking for extended range, might be using the AirPort as a repeater). I'm hookig it up to a DSL modem. The DSL works fine when connected to the AirPort, or directly to my computer (Dell laptop), but it won't work going through the router.

When I hook it up to the router, the modem assigns the router an address over DHCP, the same IP as the AirPort Express, with the right subnet mask and server IP. My computer is connected to the router over Ethernet, and has a good DHCP IP from the router. I can get all of the router config pages fine, but I can't get the modem config page or anything on the web. If I connect the computer directly to the modem, without resetting anything, the modem gives me a good DHCP IP, and I can get the modem config page and the web fine.

Resetting everything multiple times hasn't helped. Also tried spoofing the computer's IP and turning off all of the router's firewall functions. No change.

One strange thing - the router's autoconfig wants to use PPPoE, but the computer and AirPort get a good connection with regular DHCP. Trying to use PPPoE anyways doesn't work either.

So, any ideas? Is NetGear just crap? Did I screw up something obvious?
Link Posted: 3/11/2006 7:43:15 PM EDT
I have Insight cable, when I bought a router I had to update my account information with Insight, they recognize you by your MAC address. They are seeing the routers MAC address instead of the modems and not letting you connect.

This may or may not be your problem but it sounds like it is. I had that same thing happen to me.
Link Posted: 3/11/2006 7:50:25 PM EDT

Originally Posted By Ceeter:
I have Insight cable, when I bought a router I had to update my account information with Insight, they recognize you by your MAC address. They are seeing the routers MAC address instead of the modems and not letting you connect.

This may or may not be your problem but it sounds like it is. I had that same thing happen to me.



exactly, a simple call to your isp will most likely solve the problem.
Link Posted: 3/11/2006 7:56:22 PM EDT
Also, my Linksys router can clone a MAC address. It will make the ISP think that the router is actually the modem. If your can do this you might as well try it. No reason to sit on hold with them if you don't have to.
Link Posted: 3/11/2006 7:59:14 PM EDT

Originally Posted By cruze5:

Originally Posted By Ceeter:
I have Insight cable, when I bought a router I had to update my account information with Insight, they recognize you by your MAC address. They are seeing the routers MAC address instead of the modems and not letting you connect.

This may or may not be your problem but it sounds like it is. I had that same thing happen to me.



exactly, a simple call to your isp will most likely solve the problem.



Nope, my computer worked directly connected to the modem, even though it had never been connected before. I cloned it's MAC with the router, and that still didn't work.

I have had that problem before when trying to connect my computer to someone else's internet connection. A reset of the modem always took care of it.

FWIW, most good routers can clone the MAC address of a computer, so that you don't have to have your ISP change it, or reset the modem.
Link Posted: 3/11/2006 8:06:54 PM EDT
well then the router could be bad.

netgear routes suck im my opinion. try getting that one replaced under warranty. you will want to take it to the range with you after you get done talking to them
Link Posted: 3/12/2006 9:20:59 AM EDT
All of the DSL companies around here use PPPoE, do you know if your company requires it?

As for Netgear... I'm not a fan of their stuff either. I always use Linksys first, then D-Link for my clients.

-d
Link Posted: 3/12/2006 6:46:05 PM EDT
Update:

Swapped to a LinkSys router, just like the one at my house. No change in the behavior. Then I finally look around the web some more, and discover that since the DSL modem that I have has it's own router, connecting another router with Ethernet to it causes it to not work. Something about having two DHCP servers on the same subnet or something.

The solution is to switch the DSL modem to ethernet forwarding mode, and then use the LinkSys router's PPPoE to connect up. Using a wireless access point also works, which is what the AirPort Express was doing. So, I'm now surfing ARFCOM over WiFi with hidden SSID and 40 bit WEP encryption (I've been wanting to switch this place to WPA, but one of the computer's wireless cards doesn't support it - oh well, WEP's better then nothing).

So keep that in mind, kids - two routers on the same network causes headaches. At least on household-sized installs.
Link Posted: 3/12/2006 7:27:40 PM EDT
[Last Edit: 3/12/2006 7:29:18 PM EDT by Dave_A]

Originally Posted By mace:
I've been having a pretty strange problem here. Any fellow geeks have any ideas? We just bought a NetGear wireless router to replace an AirPort Express base station (looking for extended range, might be using the AirPort as a repeater). I'm hookig it up to a DSL modem. The DSL works fine when connected to the AirPort, or directly to my computer (Dell laptop), but it won't work going through the router.

When I hook it up to the router, the modem assigns the router an address over DHCP, the same IP as the AirPort Express, with the right subnet mask and server IP. My computer is connected to the router over Ethernet, and has a good DHCP IP from the router. I can get all of the router config pages fine, but I can't get the modem config page or anything on the web. If I connect the computer directly to the modem, without resetting anything, the modem gives me a good DHCP IP, and I can get the modem config page and the web fine.

Resetting everything multiple times hasn't helped. Also tried spoofing the computer's IP and turning off all of the router's firewall functions. No change.

One strange thing - the router's autoconfig wants to use PPPoE, but the computer and AirPort get a good connection with regular DHCP. Trying to use PPPoE anyways doesn't work either.

So, any ideas? Is NetGear just crap? Did I screw up something obvious?



Check the IP addresses assigned...

If your DSL modem uses 192.168.0.1 as it's IP (very common), you MUST make sure that 192.168.0.1 is NOT being used as the IP for your router or any of your computers. This is what is actually happening with the '2 DHCP servers' schpele... The simpler method is to change the IP range that the netgear assigns to a different set of numbers...

It is VERY common to have routers and DSL modems create IP conflicts because both default to the exact same address range (192.168.0.1 - 192.168.0.254), starting with .1

Second, you may have a DNS settings problem - you may have a clear line to the Internet, but your computer does not have DNS configured, and thus it knows how to get to, 66.94.230.50, but does not know how to get that from www.yahoo.com (DNS takes the www.blah.com address you type in and translates it into an IP number - it's like asking 411 for 'Tom's House', and them giving you a phone number) . In this case, you may need to manually enter your DNS servers into the router or your computer...

Oh, and then there's the MAC address trick...
Link Posted: 3/13/2006 3:45:11 AM EDT
my modem does the same thing. it is a dhcp server. and has a built in firewall. this is a speedstream 5200 btw

you can change the modem back to a dummy device. by turning if off turning the modem back on hold the reset buttom for 3 sec, untill a light flickers red. then release. it will turn the firewall and dhcp server off.


you can access the modem from any system on the network by typing SPEEDSTREAM at the address bar. it asks for a username and password. and their is the setup utility. its very convient to check packet loss and it shows your ip. all kinds of helpfull stuff.

AGAIN if you call your isp they will help you set it up so it will work properly. i do that stuff EVERYday a simple call would have saved you all this trouble.
Link Posted: 3/13/2006 4:16:30 PM EDT
This one has a config page too - that's how I changed it to Ethernet Forwarding mode. Works fine like that, no DNS problems. I suppose I could also have changed the router to use 192.168.2.x instead, but this works well enough, and seems simpler. I guess switching the router out wasn't necessary after all, but if that's the biggest mistake I make this year, I'll be doing pretty good.
Top Top