Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Site Notices
1/22/2020 12:12:56 PM
Posted: 9/13/2009 10:49:06 PM EST
[Last Edit: 9/13/2009 10:52:56 PM EST by A_Free_Man]
Rig: Icom 718.

Interface: Rigblaster Plug & Play. With the Icom 718 it requires an 8-pin DIN to 13-pin adapter. The 8-pin DIN plugs directly into Yaesus such as the 897 or 857. Also requires a cable for CI-V or rig control, 1/8" mono plug on the radio end (plugs into "Remote" jack) to 1/8" stereo plug on the other (plugs into Rigblaster P&P's Rig Control jack).

Soundcard: iMic. Since the laptop I am using has no Line In / Line Out, I'm using the iMic, which has 1/8" stereo jacks and plugs into the computer via USB.


I use the iMic also for recording LP's via Line Out (or "Tape Out") jacks on my stereo system via my laptop. I then run a pop/click filter, and then burn to CD, and archive the rare and irreplacable LP's.

Digital Software: Ham Radio Deluxe and Digital Master 780. HRD is their rig control software, DM780 is the digital program.

Problem, Icom 718 lacks the TX command in CI-V, so though DM780 produced the digital signal, the radio would not go into TX. I worked around this a bit by clicking Send or Auto button in DM780, while pressing the PTT button on the mic. This was not cool.

This is not just a problem with the Rigblaster Plug & Play, it has been reported with other interfaces, and similar problems with other radios.

I finally found a workaround. Simply don't use Ham Radio Deluxe. Why do you need it? The radio is right there, lotsa buttons and knobs and stuff right on the front of the radio. You can work the radio without HRD. Seriously, I would like to take advantage of some of the features in HRD, and I'll keep looking for a solution to this problem.

There is a conflict between the Icom 718, HRD, and DM780 that keep it from working PTT. Solution for now, don't start HRD via the desktop menu. Yeah, I had been starting HRD, then in there, clicking the DM780 button on the toolbar to start DM780. I went into the start menu, Right Clicked and copied the DM780 shortcut icon in the HRD folder, and pasted to the desktop. Start ONLY DM780.

At the top Tools > Program Options > Soundcard tab, make sure the iMic (or whatever sound card you use) is selected for both input and output devices.

Now in Program Options, PTT tab, under COM Port in the upper left, check "via Serial (COM) Port", by "Port" in the drop down select your Rigblaster's COM port (you can find this in the computer's Device Manager), and below that, check both DTR and RTS.

Now the Icom 718 will go into TX when you send.

On the Icom 718, set the power by pushing the SET button, turn the tuning knob to the right to full power (indicated by "H"), push SET again.

Set the TX audio level to about 50%. When you transmit, with the SET button the radio, toggle between Power, SWR, and ALC. When it transmits you want power to be about 20-25 watts, and NO ALC to indicate on the meter. If ALC is limiting, you will have some distortion and spatter all over the band, making other hams very unhappy with you. And your signal will be unreadable. So, adjust the TX audio level, either there in DM780. Click Soundcard button on the toolbar, check TX, and adjust the slider up or down to set the TX level. If you want to reduce power, don't do it on the radio, but do it in the audio level. This will give a nice, clean, easy to decode signal.

In all bands, set the radio to Upper Side Band. Frequencies, 3.580 mhz, 7.070 mhz, 10.140 mhz, 14.070 mhz, 21.070 mhz, and 28.120 mhz. USB all bands, even 80 and 40 meters. For the Icom 718, normally in 80 and 40 meters the Mode button will skip past USB. Just press and hold the MODE button about 1 second, and it will change from LSB to USB.

So, that's it. I made QSO's with NY, VA, CO, Ontario, Canada, Mexico, Quatamala. With 25 watts... about what the lightbulb in my fridge draws. Amazing!


Edited to add:
Link Posted: 9/14/2009 4:11:20 AM EST
Congrats. PSK is about all I do these days. Hope you have better luck with the Plug & Pray than I did. Never could get it to work consistently. I haven't had a single lick of trouble since picking up a SignaLink USB. Maybe we can hook up on the air sometime.
Link Posted: 9/14/2009 11:27:33 AM EST
I'm running the signalink usb also...great unit. I've had great luck with PSK and its ability to perform.
Link Posted: 9/14/2009 11:46:33 AM EST
Bout time.

Congrats AFM!!!
Link Posted: 9/14/2009 1:15:48 PM EST
[Last Edit: 9/14/2009 1:16:53 PM EST by A_Free_Man]

If I open HRD and DM780, I can click the TX button in HRD and it will operate the PTT function, putting the radio into TX. Clicking again, it returns to RX.

In DM780 if I click the Radio button, and it throws up a mini control panel (from HRD) up on the left in its own pane, I can click the TX button on that pane, and the radio will go into TX. Clicking again, it returns to RX.

For whatever reason DM780 won't control TX. Oh well, I can live without HRD.

Anyway, I've made some good QSO's. What was really cool, my first QSO, I responded to a guy transmitting that he was testing. He came right back, it was both my AND his first PSK31 QSO's. We had a nice 20 minute QSO, 1200 miles on 20 watts. Now, that's cool!

PS, and thanks for the suggestions on the Signalink. I'll trade up as soon as I can.
Link Posted: 9/14/2009 1:53:40 PM EST
How do you have DM-780 PTT configured? You can set it to use HRD so presumably if it works through HRD it should work through DM. If you get the SignaLink then you'll set DM PTT to None - Soundcard.
Link Posted: 9/14/2009 2:06:59 PM EST
It's about frickin' time, dude! You don't have your DM780 radio control settings correct––get on it!

Seriously, I'd help you with the DM780 but I'm far away from all my radio stuff right now on business travel. Don't limit yourself to PSK! And turn on the RSID receive feature. You'll be really amazed when the little box pops up, just click it and boom––instant decode! Put an RSID transmit command into your CQ macro and you'll be amazed how many replies you get.
Link Posted: 9/14/2009 2:25:56 PM EST
Link Posted: 9/15/2009 6:22:00 AM EST
[Last Edit: 9/15/2009 6:26:46 AM EST by KB7DX]
I had trouble too. It was all in the dm780 settings dealing with "server client" or something like that. Basically you have to tell dm780 to key the rig through hrd.

ETA–– click the "tools" tab..click "program options" then PTT. Select middle option, key through HRD. Follow the link there and set up the link between HRD and DM780.
Link Posted: 9/15/2009 10:00:28 AM EST
Originally Posted By KB7DX:
I had trouble too. It was all in the dm780 settings dealing with "server client" or something like that. Basically you have to tell dm780 to key the rig through hrd.

ETA–– click the "tools" tab..click "program options" then PTT. Select middle option, key through HRD. Follow the link there and set up the link between HRD and DM780.

Tried that, and for some reason it didn't work. Then set it to key through the COM port, that works only if HRD is not running. This is a problem between the two programs and the Plug & Play. And a known (I know now) problem. Others have the same.

I'm going to try some other things, but meanwhile, I don't really need HRD.

Anyway, this is fun.

Link Posted: 9/15/2009 4:38:31 PM EST
Ok, I see. I built my own interface and went round and round with it until my buddy showed me the light...and the software fix.
I'm a hardware guy..not software.
Link Posted: 9/15/2009 6:07:08 PM EST
I can try getting my P&P working again if you think it'd help and then I can share what I did. Might be a couple of days, though, since we're heading out of town.
Link Posted: 9/15/2009 8:40:58 PM EST
OK, I got DM780 working with HRD now via the Rigblaster Plug and Play.

I don't know what the problem was before... I could not get it to work by checking to Tx via HRD (the middle check), but I was advised to try that again.

I went back into the PTT tab in Program Options (F8) in DM780 one more time, read it very carefully. It said to configure DM780 to tx through HRD by opening the Radio pane, using the button there. Previously I had clicked the blue configure link there in the PTT tab. But I did as it said, opened up the Radio pane via View, and voila. Now it's working. About time!

Link Posted: 9/16/2009 3:07:09 AM EST
Link Posted: 9/16/2009 6:21:54 AM EST
Link Posted: 9/18/2009 11:36:26 PM EST
QSO's: Costa Rica, Mexico, Cuba, Venezuela, and heard some guys in France, Germany, Italy, Spain, Portugal.

And a Feld Hell QSO, too! A guy asked me if I could do Feld Hell. He needed my state in Feld Hell to get a Worked All States for that mode. I said, I don't know, but from the Mode drop down, DM780 can. We went up to 7.040 mhz (from 7.035 mhz) and I switched to Feld Hell. Just clicked on it in the drop down, no other changes to adjustments in my sound card levels or the radio. And he reported a very good signal, 599.

Playing radio is fun. And playing digital is more fun.

Link Posted: 9/19/2009 4:04:32 AM EST
Sweet. I love the digital modes. I'm sure you'll have a blast.

Join the 070 and European PSK (EPC) clubs.
Link Posted: 9/20/2009 5:42:26 AM EST
[Last Edit: 9/20/2009 5:42:55 AM EST by charliez]
What antenna setup do you use? and from which state?
Link Posted: 9/20/2009 8:41:05 AM EST
Originally Posted By charliez:
What antenna setup do you use? and from which state?

I live in a southern state, use a multi dipole, legs cut for 75, 40, and 20 meters. SWR 1.2-1.3 on those bands, but for the lower half of the 80 m band, where the tuner helps. 17 meters is 3.5:1, 15 meters 3:1. Both tune easily to 1:1. 12 meters is highest, 5:1, but the tuner will tune it. 10 and 6 metes are both 2:1.

The poor tuner tries but just can't find a tuning solution for 160 meters. That's OK, just the same 6 or 8 old farts every night, talking about the same thing, coon dogs, fishing, and amplifers. A pretty closed little clique... I don't think newcomers are welcome. Hahaha... And like a friend says, "I don't know anybody with enough real estate for 160 meters.

For PSK31 I'm using 20 meters during the day until about 19:30 or so, and 40 meters from about 18:00 until I get tired.
Top Top