Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
9/22/2017 12:11:25 AM
Posted: 8/13/2005 7:19:37 PM EDT
I have an Eotec on my Bushmaster A3. The locking screw always seems to work lose after a couple hundred rounds or so. No matter how much I tieghten it, it still works it's way loose. It's beginning to become a chronic problem. Has anyone else had this problem or have a solution?

Thanks, RedDawg6
Link Posted: 8/13/2005 7:27:52 PM EDT
Link Posted: 8/13/2005 7:29:31 PM EDT
A touch of blue loctite.

Are you using the hex nut or thumb screw? My thumbscrew never comes loose with a quarter to tighten it up.

Link Posted: 8/13/2005 7:37:18 PM EDT
I have the thumb Screw. I'll try some blue loctite and see if that solves the problem. Sounds like the cheapest fix and the first thing I sould try.
Link Posted: 8/13/2005 7:38:34 PM EDT

Originally Posted By RedDawg6:
I have the thumb Screw. I'll try some blue loctite and see if that solves the problem. Sounds like the cheapest fix and the first thing I sould try.



I would try using a coin to tighten it without the loctite first. Snug plus.

Again, mine never comes loose.

Link Posted: 8/13/2005 9:22:59 PM EDT
EOTech...
EOTech...
This aint Texas...
EOTech...
Link Posted: 8/13/2005 9:40:16 PM EDT

Originally Posted By Da_Bunny:
EOTech...
EOTech...
This aint Texas...
EOTech...



It finally happened.

The bunny is rabid.

Link Posted: 8/13/2005 10:18:29 PM EDT
Wait till Tom S pulls out the list of "Da_Bunny deals" people have asked for when he gets there.....
Link Posted: 8/13/2005 10:35:35 PM EDT

Originally Posted By CavVet:

I would try using a coin to tighten it without the loctite first. Snug plus.

Again, mine never comes loose.



+1
I use the thumb screw also and snug plus 1/4 turn with a coin(as per the destructions) it hasn't come loose.

DD
Link Posted: 8/14/2005 9:37:31 AM EDT
Link Posted: 8/14/2005 10:13:38 AM EDT

Originally Posted By CavVet:

Originally Posted By Da_Bunny:
EOTech...
EOTech...
This aint Texas...
EOTech...



It finally happened.

The bunny is rabid.




And to think I had to read the title to this thread about five times before I didn't think it said "Erotic mounting problems".....
Link Posted: 8/14/2005 10:21:26 AM EDT

Originally Posted By Teknic:
DON'T Use Locktight. There is no reason too.



A lot of people do use Loctite, I would use the blue if I had too, its a non issue for me though.

I see fdromt hat thread there is a plastic washer deal. If you call Dennis, he will take good care of you.
Link Posted: 8/14/2005 11:05:09 AM EDT

Originally Posted By RedDawg6:
I have an Eotec on my Bushmaster A3. The locking screw always seems to work lose after a couple hundred rounds or so. No matter how much I tieghten it, it still works it's way loose. It's beginning to become a chronic problem. Has anyone else had this problem or have a solution?

Thanks, RedDawg6



There is a locking cam system similar to an arms mount thats made specifically for the EOTechs to lock them in place firmly, but not as permanent as locktight.

Teknic has them in stock and can fill you in on the details.

Link Posted: 8/14/2005 1:45:25 PM EDT
SELL IT!!

Get one of these:


AND one of these:


PROBLEM SOLVED!!

Top Top