Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
9/22/2017 12:11:25 AM
Posted: 9/17/2005 8:55:15 PM EDT
I have a Springer GI 5 inch. got about 1000 rounds through it now and today it gave me my first problem. the slide would lock open after every shot! no this only started hapening after about 120 rounds and let me add that i had been going through the rounds quick. I mension this because it was flawless through the first 120 then the problem started. Set the gun down and shot my 24/7 for a while. came back to the springer to see what the prob was and another 75 rounds went through flawless ??? also I had done some upgrads prior to going to the range, added houge grips, extended slide stop and a wilson combat triger, and polished the entire barrel and feed ramp to a mirror finish. what do you think? was this a heat issue? or was there a part I added that was failing?
Link Posted: 9/17/2005 9:32:47 PM EDT
Not to be insulting, but move your thumbs away from the slide stop. Someone else posted this same problem and didn't realize that it was his grip. Their thumb was putting pressure on the slide stop.
Link Posted: 9/17/2005 9:42:21 PM EDT
sorry should have said I checked that right away when it started but even with holding lower it was still happening. any other sugestions?
Link Posted: 9/17/2005 10:01:13 PM EDT
Is the slide locking fully open? Or is it half way where a round has not completely chambered? It might be time to change out the recoil spring. I like Wolff, either their factory weight or the 18.5lb. Sometimes the original spring takes more abuse during the initial break-in period. If the spring on your S/A is the original I would change it...can't hurt. Also, you mentioned the slide stop, it may have too much metal on the area that faces the feed area. Check it and see if there is brass marks on it. If so then this is most likely the problem. As the gun feeds the round is making contact with this portion of the slide stop causing it to engage primaturely. If you have a finishing file or some fine grit sandpaper w/ a little gun oil, lightly go over the area of the slide stop with the brass marks until they disappear and then do a couple more passes and your problem should be solved.
Link Posted: 9/17/2005 10:51:26 PM EDT
the slide is locking open like the mag is empty. gotta hit the slide release to let it go to battery.
Link Posted: 9/18/2005 5:30:43 AM EDT

Originally Posted By oseprophecy:
I have a Springer GI 5 inch. got about 1000 rounds through it now and today it gave me my first problem. the slide would lock open after every shot! no this only started hapening after about 120 rounds and let me add that i had been going through the rounds quick. I mension this because it was flawless through the first 120 then the problem started. Set the gun down and shot my 24/7 for a while. came back to the springer to see what the prob was and another 75 rounds went through flawless ??? also I had done some upgrads prior to going to the range, added houge grips, extended slide stop and a wilson combat triger, and polished the entire barrel and feed ramp to a mirror finish. what do you think? was this a heat issue? or was there a part I added that was failing?



This could be your problem. Either the 'extended' pad is hitting your thumb + locking slide open, or as JCG4 stated, the bullet noses are hitting the part of the slide stop that is actuated by the mag follower. Put the standard slide stop back in and see if the problem goes away.
I had the same problem once before - it was the slide stop.
Link Posted: 9/18/2005 4:50:46 PM EDT
Link Posted: 9/18/2005 5:25:12 PM EDT
I had a problem when I bought an XD. I was used to High Thumbs grip with a 1911 and my right hand's thumb kept hitting the slide stop enough to hold it down. Instead of the weapon failing to return to battery, like yours, my XD returned to battery after the last round extracted. I retrained to use Thumbs Down with my right thumb holding my left thumb down. My XD problem stopped.
Link Posted: 9/19/2005 8:52:41 AM EDT
well took the slide release out and there is brass markings on it like what you guys said to llok for. was fine the rest of the day that i shot it, hope it wore in. if not i'll have a file and the original slide release with me next weekend :) thanks for the help
Link Posted: 9/19/2005 3:27:53 PM EDT
Cool.
Top Top