Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Posted: 6/7/2009 10:32:26 PM EST
I just bought a P-11 and am looking for some defensive ammo recommendations. I know that so HPs have trouble
feeding and was wondering what you guys have found works best?

I fired about 100 rounds of wincheter FMJs my frist trip out with no problems.
Link Posted: 6/8/2009 11:07:25 AM EST
I've had no problems with a few hundred WWB 115- and 147-grain JHP's. The same for a smaller quantity of Federal 9BP.
Link Posted: 6/8/2009 11:20:55 AM EST
ok thanks. I'll have to try those out next time I'm able to pick some up.
Link Posted: 6/12/2009 5:35:30 AM EST
I carry Federal HPT's and haven't had a feed issue with them.

Oh, and they do this....

Link Posted: 7/8/2009 7:52:27 AM EST
Originally Posted By Dogue:
I carry Federal HPT's and haven't had a feed issue with them.

Oh, and they do this....

http://www.fsguns.com/images/a7698140ce325d46aea925c2d4c6a3e6_small.jpg


I carry Federal HST's.
Link Posted: 7/8/2009 11:27:08 AM EST
Originally Posted By eddymunster:
Originally Posted By Dogue:
I carry Federal HPT's and haven't had a feed issue with them.

Oh, and they do this....

http://www.fsguns.com/images/a7698140ce325d46aea925c2d4c6a3e6_small.jpg


I carry Federal HST's.

P or S (they're so close together on my keyboard)...but, yes, that's also what I use.

Link Posted: 7/8/2009 11:53:41 AM EST
My P-11 seems very fond of Win Silvertip HP, so that's what I've been using.
Link Posted: 7/10/2009 6:17:14 AM EST
I feed mine either 124gr +p gold dots or 124gr +p winchester bonded, no problems
Link Posted: 8/1/2009 1:54:29 PM EST
sorry to steal the tread but i am needing to find something out kinda fast. just got a p11 and i am having alot of noise in the clip any time you move the gun sounds like a maracha.
anyone know how to fix this
Link Posted: 8/1/2009 2:01:30 PM EST
[Last Edit: 8/1/2009 2:03:10 PM EST by fishngrits]
I fed mine 124 gr. Gold Dots. No problems ever.


Mac,
I posted about your mag problem in your other thread.
Link Posted: 8/24/2009 2:33:46 PM EST
147 grain Winchester Rangers
Link Posted: 8/24/2009 4:03:14 PM EST
I'll let you know after the factory returns mine with the ejector properly repaired...
Link Posted: 9/13/2009 8:17:28 AM EST
I run WWB 115gr HP in mine without issues. Only thing I have done is polished the feed ramp.
Link Posted: 9/28/2009 5:01:28 PM EST
[Last Edit: 9/28/2009 5:01:41 PM EST by Texkaw]
I use Speer Gold Dot JHP +P 124 gr.
Link Posted: 9/28/2009 5:02:07 PM EST
Originally Posted By brdvictim:
I run WWB 115gr HP in mine without issues. Only thing I have done is polished the feed ramp.


You use WWB for defensive ammo?

Link Posted: 9/28/2009 5:02:48 PM EST
Originally Posted By MacThePunisher:
sorry to steal the tread but i am needing to find something out kinda fast. just got a p11 and i am having alot of noise in the clip any time you move the gun sounds like a maracha.
anyone know how to fix this


Yeah, get the 12 rounder.


Link Posted: 9/30/2009 11:53:50 AM EST
Originally Posted By Texkaw:
Originally Posted By brdvictim:
I run WWB 115gr HP in mine without issues. Only thing I have done is polished the feed ramp.


You use WWB for defensive ammo?



I carry 124 +p gold dot, 124 +p Ranger bonded, or 124 HST. if im carrying 9mm

However wwb is not a bad load like some would think. their wwb 147jhp expands just as good or better than some of the more expencive stuff. I dont think I would be carrying 115gr though.
Link Posted: 9/30/2009 2:02:52 PM EST
Originally Posted By Texkaw:
Originally Posted By brdvictim:
I run WWB 115gr HP in mine without issues. Only thing I have done is polished the feed ramp.


You use WWB for defensive ammo?



Sure do. It is accurate in my gun.
Link Posted: 10/25/2009 6:46:27 AM EST
5.5grs of unique pushing a 115gr XTP.
Yeah, I know about reloads and CCW.
So far this load has been 100% out of my P11. As for accuracy, I think the gun is the limiting factor, not the ammo.
Link Posted: 11/4/2009 5:28:33 PM EST
Originally Posted By Hb2:
I'll let you know after the factory returns mine with the ejector properly repaired...


Mine did the same thing when I fired, for the first and last time, +P ammo. I got it put back together and vowed never to shoot anything over regular pressure again through the P11.
Top Top