Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
9/22/2017 12:11:25 AM
Posted: 9/21/2005 8:13:52 AM EDT
I posted this in the Kel-Tec forum too but it does not seem to get much traffic, so I thought I would try here too:

I have a P3AT and I am having problems with FTEject. I had no problems with the 1st 50 or so shots but now on every shot the slide moves back but does not pull the case out and then sticks back on the edge of the next round. There is a mark from the extractor trying to pull it out but it is like the tension from the mag is not letting the round come out or the extractor is not getting a good hold of it when pulling. It only happens when shooting if I cycle it by hand I have no problem. I have two mags and it does the same thing with both... Can anybody help? Any others having this problem or have a solution? I ran out of ammo the last time I shot so I did not mess with it for so long so maybe ( I hope) it will just fix itself. It is the type 2 extractor btw and I will take pictures the next time I go to the range if possable.

Thanks!!!
Link Posted: 9/21/2005 8:16:15 AM EDT
[Last Edit: 9/21/2005 8:16:57 AM EDT by bigbore]
Link Posted: 9/21/2005 8:26:12 AM EDT
[Last Edit: 9/21/2005 8:26:50 AM EDT by TruePunisher]
I know nine people that have them and they have no problems.

I like it and it fits my pants better then a revolver. I have my reasons I like it just as you have your reasons you don't I just want it to work.
Link Posted: 9/21/2005 6:47:14 PM EDT
Top Top