Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
PSA
Member Login

Site Notices
Posted: 2/24/2016 9:14:55 PM EDT
Last night I took my gen4 G19 apart to swap out trigger bars.  The 2 small pins popped out easy, the larger diameter pin was somewhat hard to get out.  Finished the swap, and put it back together.  Again the smaller diameter pins went back in easy, the larger pin was hard to get back in.  Function tested/dry fired no problems.  Everything worked.

Today, I decide to do the 0.25 trigger job.  The 2 small diameter pins pop out no problems, but the larger diameter pin won't move.  I tried tapping it out with with a punch and hammer, no luck.  I then started hitting it with a good amount of force, still won't budge. I polished what I could with it assembled and put it all back together.  Function test and about 100 dry fires tonight.  No problems.  

What gives?  What am I missing? Could it be slightly bent in there somehow?
Link Posted: 2/24/2016 9:19:34 PM EDT
Never use a hammer and punch, All you need is a punch and  wiggle slide release lever and put pressure on pin at same time,take out pin left to right. Replace pin right to left.
Link Posted: 2/25/2016 12:08:38 AM EDT
Fixed! $0.25 trigger job complete!

Thanks for the tip on playing with the slide release bar.  After doing that, the pin came out somewhat easy.
Top Top