Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
BCM
Member Login

Posted: 5/26/2008 1:00:14 PM EDT
I dont understand the screw slot on the trigger pivot pin.

Any tips on getting the takedown lever out?
Link Posted: 5/26/2008 2:13:38 PM EDT
Don’t have a P6.

On later SIG’s, you simply rotate the takedown lever either direction in full circles while pulling it out (and while pushing the opposite end to help get it out).  Keep rotating and pulling and ultimately you’ll get it completely out.

Then lift the locking insert out.

Then push the trigger pivot pin out.

The slot in the pin simply helps you align it correctly during reassembly.   It has nothing to do with disassembly.
Link Posted: 5/26/2008 5:06:50 PM EDT
Yup, that's exactly how to pull the trigger pin. I'll email you a copy of the armourer's manual to verify.

Good Luck!

Jeff

ETA: Oops! No way to send attachments. IM me an email address and I'll send you a PDF copy of the manual.
Link Posted: 6/1/2008 12:20:10 PM EDT
ok but hold on, how do you get it back together!

I took mine apart to refinish it.  I finished refinishing it, BUT now I can't get the freaking thing back together.  

I have the trigger pin back, the hammer is locked back and the trigger is all the way back, but that shiny locking block (?) with the feed ramp on it won't go back far enough to get the take down lever back in.  I can't rotate the trigger pin and can't get anything to move.

any suggestions?  

can I get a copy of that armorers manuel to see if it has that in there?
Link Posted: 6/1/2008 12:23:29 PM EDT
according to the parts diagram here: www.sigsauer.com/CustomerService/documents/CLASSICPISTOLOM.pdf

the part I can't get to move back is the "locking insert"
Link Posted: 6/1/2008 12:25:18 PM EDT
Link Posted: 6/1/2008 12:33:30 PM EDT
would that also stop the trigger and hammer from being able to move?
Link Posted: 6/1/2008 12:36:51 PM EDT
oh yea and the locking insert is also not moving.
Link Posted: 6/1/2008 12:41:58 PM EDT
GENIUS!  you are right it was 180deg off.

I pulled the trigger bar out of the hammer to release it.  then the locking insert fell out.  rotated it 180deg and then slipped it back in.  then everything just slipped back in!

now all I have to do is order the mag relase connector that popped out across the garage when I took it apart!
Link Posted: 6/4/2008 4:13:33 AM EDT
Link Posted: 6/4/2008 12:51:44 PM EDT
yea tell me about it.  normally I take parts like that apart in a bag....just in this case I didn't think that was how to take it apart...

no chance you guys sell that catch stop with out charging $10 shipping for  it do you?  it seems to be a $5 part and I don't think it really takes $10 to ship it!
Link Posted: 6/4/2008 2:10:16 PM EDT
I am the cheapest SOB there is!  I actually found the part in the garage! it was in the back of my jeep.  doesn't sound like much until you see the jeep.  it hasn't been cleaned since the last 4wheeling trip.  

either way my sig is now up and functional again!
Top Top