Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Site Notices
Posted: 8/2/2009 4:27:22 PM EST
I have an 03 lancer that suddenly today, the sun roof stopped half way, making a grinding type noise
then wouldn't go any further. Its like it off set and then thought it was closed. After further inspection
the motor just wouldn't turn off making the same noiseuntil i disconnected the battery to the car. For now,
i removed the fuse to the sun roof until i figure it out.

Sunroof has always worked great for me which is why I'm a bit confused. I don't have the doe
to just have it looked it so I'm asking you guys before I send it in.

Any ideas as to what might be wrong? off the track? debris on the track? Motor dying?
How much is a motor?

Thanks
Link Posted: 8/2/2009 4:45:02 PM EST
[Last Edit: 8/2/2009 4:46:21 PM EST by kevhogAZ]
Easy fix, buddy. Pull the headliner down in the rear, over the rear seat. You don't have to remove it from the car, just lower it in the rear enough, to get at the motor. You'll see the 10mm bolts that hold the sunroof motor to the gear, have come loose. Slowly tighten the bolts, and you'll be back in business. Be careful that the teeth on the motor, and the teeth on the rails line up.

99% of the time when we saw a Lancer with a sunroof inop, the bolts had just come loose.
Link Posted: 8/2/2009 7:55:23 PM EST
Originally Posted By kevhogAZ:
Easy fix, buddy. Pull the headliner down in the rear, over the rear seat. You don't have to remove it from the car, just lower it in the rear enough, to get at the motor. You'll see the 10mm bolts that hold the sunroof motor to the gear, have come loose. Slowly tighten the bolts, and you'll be back in business. Be careful that the teeth on the motor, and the teeth on the rails line up.

99% of the time when we saw a Lancer with a sunroof inop, the bolts had just come loose.


Thanks a bunch, I'll try this in the morning and report back. Hope this works.

Top Top