Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Posted: 10/29/2006 8:03:06 AM EST
The toolbox I have in the bed of my truck has a broken internal locking mechanism. I need to figure out a way to lock the box on the outside. Any realistic suggestions would be greatly appreciated. I don't want to have to sell this one for a big loss just to buy a new one similar to it. Here's the one I have.

Link Posted: 10/29/2006 8:07:50 AM EST
Pop-A-Lock

or

Link Posted: 10/29/2006 8:11:34 AM EST
I have no problems opening the lid. I'm trying to secure the contents of what is inside.
Link Posted: 10/29/2006 8:15:37 AM EST
Link Posted: 10/29/2006 8:18:21 AM EST
[Last Edit: 10/29/2006 8:19:54 AM EST by bamaslam]
If you can weld or TIG, use two L pieces with a 90degree bend of steel or aluminum, use a cutting torch or big drill and put a hole in both pieces big enough to put a master lock through, weld or tig those two pieces on the lid and the base of the box so that the holes in each piece line up, then put a masterlock through it.

Sorry if that's hard to understand, I haven't slept in a while.

ETA Or save a lot of trouble and buy what Hanau suggested.
Link Posted: 10/29/2006 11:39:12 AM EST
I'm have no way to weld something. The picture above, how would you mount it? This is fairly flimsy aluminum.
Link Posted: 10/29/2006 11:42:01 AM EST
Call Kobalt and get new locks and keys?
Link Posted: 10/29/2006 11:52:02 AM EST
Either get new locks from the company, or bolt a hasp (or better two hasps, one near each end) onto the thing and lock it with QUALITY padlocks...
Link Posted: 10/29/2006 12:05:00 PM EST

Originally Posted By BigDawg308:
I'm have no way to weld something. The picture above, how would you mount it? This is fairly flimsy aluminum.


drill holes where the mounting holes are and cut a piece of flat steel and drill same holes thru it.
then but bolts thru the hasp, toolbox, steel plate then tighten nuts down.
do it for both sides.
Link Posted: 10/30/2006 6:00:10 AM EST
[Last Edit: 10/30/2006 6:54:36 AM EST by BigDawg308]
Disregard. I got it fixed. Thanks for the help.
Top Top