Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Site Notices
Posted: 8/10/2011 7:35:58 PM EDT
Have not used the boat for a while but the trim was working when I put it away. What I am getting now is just a clicking at the solenoids. I replacedboth of them today hoping that was the problem but no dice. Hopefully someone here has a little experience with these.The wife and I are supposed to be taking a few boyscouts from my sons troop this weekend if we can get it running. Any help would be greatly appreciated. !

the 2 solenoids


Trim motor


Link Posted: 8/10/2011 8:38:12 PM EDT
battery charged? and good contacts from battery to cables?
Link Posted: 8/10/2011 8:50:26 PM EDT
Oil in the hydraulics?
Link Posted: 8/10/2011 10:45:45 PM EDT
I had problems years ago with an old '74 Mercury 115 and the power trim just making noise and not doing anything. Turned out being a leak in one or more of the high pressure hoses due to age deterioration of the material. There was a crack in the hose and when the tilt motor was activated the oil would just shoot out into the bilge area. Got new hose lines, put new oil and this solved my problems. Have someone operate the tilt motor switch while you look at the hoses for oil shooting out. Good luck.
Link Posted: 8/10/2011 11:20:14 PM EDT
[Last Edit: 8/10/2011 11:37:15 PM EDT by jchewie1]
The trim system on my parents' boat had an enclosed circuit breaker that would pop without warning. It was reset with a small red push button on the motor about 3/8 inch in diameter.
Check for a circuit breaker or fuse first.

There should be oil in the hydraulic system, otherwise you would hear the motor going.
Check your battery as well.


J.


That little phillips screw cover may be a fuse holder on top of the trim pump. Check that.
EDIT - Closer look makes that screw head look like an actual screw and not a cover. My bet is on fuse, circuit breaker, or similar. You could have an inline fuse as well.
Link Posted: 8/11/2011 1:41:17 AM EDT
[Last Edit: 8/11/2011 1:44:38 AM EDT by SIRIUS1]
Start by ensuring that your battery is charged as it can easily muster the current to click relays yet still not have enough to instigate the trim pump.

I would start by probing with a test light the large blue UP wire going to the pump or the large green DOWN wire.

Connect the test light clip to the battery's negative terminal stud, touch the test light probe to the positive stud to check the bulb and then probe one of the wires while simultaneously throwing the trim switch in the direction that corresponds.

If it lights up your problem is in the pump or is with the pump ground.

If it is a brush contact issue in the pump, simply rapping on it near the top where the wires go in with a rubber hammer, while activating the switch may be enough to get it spinning.

You might want to look inside.




This link should provide you with the help you need. Troubleshooting Mercruiser Trim Pump


This link addresses a different problem but explains the wiring fairly well too. More Troubleshooting.




Good Luck.
Link Posted: 8/12/2011 8:09:25 PM EDT
[Last Edit: 8/12/2011 8:12:56 PM EDT by Blaze454]
Got it going this evening. Finally just pulled it off the boat and disasembled it. Water had worked its way in through the upper seal where the electrical ends up. Needless to say some of my favorite gun cleaning foam and a bit of cussing I got it back together and it worked like new.

Top Top