Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Site Notices
Posted: 6/16/2009 5:40:06 AM EST
Please help, I'm having the hardest time getting s router connection to work. Here are the details:

I have two Cisco 1841 routers connected via a point-to-point t1 line between our office and remote data center.

I can pass traffic back and forth across the link using hard coded ip addresses but I cannot get DNS or DHCP to come across the link. I have configured relay agents as best I can but for some reason it doesn't seem to be working.

Link Posted: 6/16/2009 7:40:04 AM EST
[Last Edit: 6/16/2009 7:45:18 AM EST by NimmerMehr]
relay agent on the router itself, for dhcp?

(i never heard of a relay for dns, as it is not limited to layer2 broadcast)

ok, no firewall or acls? routes are correct? (static or learned) a host on network a can ping a host on network b?

Edit: Is the router RFC3514 compliant?
Link Posted: 6/16/2009 7:46:52 AM EST
How did you configure the router? SDM or CLI?
Are ACL's in place blocking the traffic?
Did you run any debugs and watch what is happening?
Do you have the interface asking for DHCP addresses?
When working with DHCP and routers I have had to sometimes reboot the router.
Can you post a scaled back version on your running config?
Link Posted: 6/16/2009 9:16:46 AM EST
Here are the configs. Oddly enough, exchange will connect w/o DNS passing properly but there isn't any name resolution or DHCP coming back from teh remote network.

remote router:

Current configuration : 1921 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname DR-1841-01
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings

aaa new-model
!
!
!
aaa session-id common
clock timezone EST -5
clock summer-time EDT recurring
ip cef
!
!
ip dhcp smart-relay
ip dhcp relay information option
ip dhcp relay information policy keep
ip dhcp relay information trust-all
!
!
ip domain name <>
ip name-server 10.1.20.11
ip name-server 10.1.20.12


!
!
!
!
interface Loopback0
ip address 10.1.254.2 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.50.2 255.255.255.248
ip helper-address 10.1.20.1
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.10.51.2 255.255.255.248
duplex auto
speed auto
!
interface Serial0/0/0
ip address 192.168.53.5 255.255.255.0
!
router odr
!
router ospf 1
router-id 10.1.254.2
log-adjacency-changes
network 10.1.50.0 0.0.0.7 area 0
network 10.1.254.2 0.0.0.0 area 0
network 10.10.51.0 0.0.0.7 area 0
neighbor 10.10.50.2
!
ip forward-protocol nd
ip route 10.10.0.0 255.255.0.0 10.10.50.2
ip route 10.10.0.0 255.255.0.0 192.168.53.3
ip route 10.10.20.0 255.255.255.0 203.145.55.4
ip route 10.10.20.0 255.255.255.0 10.10.50.2
ip route 192.168.53.0 255.255.255.0 10.1.50.1
!
ip http server
ip http access-class 23
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
access-list 101 permit udp any any eq domain
access-list 101 permit udp any eq domain any
!
control-plane
!
!

scheduler allocate 20000 1000
end

local router:

Current configuration : 2109 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec

!
hostname HQ-1841-01
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings

aaa new-model
!
!
!
aaa session-id common
clock timezone EST -5
clock summer-time EDT recurring
ip cef
!
!
ip dhcp smart-relay
ip dhcp relay information option
ip dhcp relay information policy keep
ip dhcp relay information trust-all
!
!
ip domain name admiral.local
ip name-server 10.1.20.11
ip name-server 10.1.20.12

!
!
!
interface Loopback0
ip address 10.10.254.2 255.255.255.255
!
interface FastEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$
ip address 10.10.50.2 255.255.255.248
ip helper-address 10.1.20.1
ip helper-address 10.1.20.12
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.10.51.1 255.255.255.248
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
ip address 192.168.53.3 255.255.255.0
!
router ospf 1
router-id 10.10.254.2
log-adjacency-changes
network 10.10.50.0 0.0.0.7 area 0
network 10.10.51.0 0.0.0.7 area 0
network 10.10.254.2 0.0.0.0 area 0
neighbor 10.1.50.2
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.1.50.2
ip route 0.0.0.0 0.0.0.0 192.168.53.5
ip route 0.0.0.0 0.0.0.0 Serial0/0/0
ip route 10.1.0.0 255.255.0.0 192.168.53.5
ip route 10.1.0.0 255.255.0.0 10.1.50.2
ip route 10.10.0.0 255.255.0.0 10.10.50.1 201
!
ip http server
ip http access-class 23
ip http authentication local

ip http timeout-policy idle 60 life 86400 requests 10000
!
access-list 23 permit 10.10.10.0 0.0.0.7
access-list 101 permit udp any any eq domain
access-list 101 permit udp any eq domain any
!

scheduler allocate 20000 1000
end
Link Posted: 6/16/2009 1:29:22 PM EST
instead of the dhcp smart-relay command try using the iphelper command.
Top Top