Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 8/19/2004 9:33:09 PM EST
I am trying to network two windows PCs. One is running XP, the other 2000. Both are plugged into a router that is plugged in to my DSL modem. Both PCs have the internet working. I would like to be able to share files between the machines. I have set the folders that I want to share as "shared" but I can't see the folders on the other machine. Any suggestions?
Link Posted: 8/19/2004 9:37:37 PM EST
Good luck! I tired this for hours the other day. NetBIOS and everything. I couldn't get shit. Ended up using Remote Desktop, which is a really fun tool by the way!
Link Posted: 8/19/2004 9:44:25 PM EST
Both workstations should be on the same workgroup. You will probally want to enable the IPX/SPX file and printer sharing and client for microsoft networks. You may not see the system right away until after you map a network drive. You can do this quickly by typing in \\machine name at the run line. At this point if you computer sees the other system it will ask you for a user name and password. Just type in the user name and password for the machine. It helps to have an administrative user and password that are the same on both machines.
Link Posted: 8/19/2004 9:45:09 PM EST
The 2 machines have to be on the same subnet and have the same subnet mask.
Like:

Machine 1 IP Address: 192.168.0.1, Subnet Mask 255.255.255.0
Machine 2 IP Address: 129.168.0.2, Subnet Mask 255.255.255.0

Don't worry about the Gateway or DNS Server IPs.

You need to have the 2 machines be in the same Workgroup, and
set the file and sharing permissions of the folders and files to be accessible
to the user who needs them.
Have fun.

Link Posted: 8/19/2004 9:57:47 PM EST
[Last Edit: 8/19/2004 9:58:46 PM EST by Troy]
Link Posted: 8/19/2004 10:08:17 PM EST
I tried all this crap with mine the other day, not to highjack. Same subnet, same workgroup, firewalls turned off, file share enabled, you name it, I tried it. The only thing I could do was see the workgroup under Microsoft Windows Network. Pretty annoying. It doesn't matter now since I transferred with RD and liked trying it out, but still.
Link Posted: 8/19/2004 10:14:07 PM EST
[Last Edit: 8/19/2004 10:15:00 PM EST by Xer0]
As you could see the worlgroup, you were almost there. Once you see the workgroup in Network neighborhood, you have to open it (double click the workgroup name) to see the individual computers and/or shares in the workgroup.
Link Posted: 8/19/2004 10:22:18 PM EST

Originally Posted By Xer0:
As you could see the worlgroup, you were almost there. Once you see the workgroup in Network neighborhood, you have to open it (double click the workgroup name) to see the individual computers and/or shares in the workgroup.



That's the strange part. Clicking it just opened another empty window? Like a shortcut but nothing else. I thought it would show something? I had the share turned on 2 different folders. I really think something else was blocking it from sharing, but I have no idea what. A Service? Policy setting?
Link Posted: 8/19/2004 10:31:51 PM EST
Link Posted: 8/19/2004 10:34:53 PM EST

Originally Posted By Troy:
Did you verify that both machines were getting an IP address, and that they were on the same IP subnet with the same subnet mask?

-Troy



Sure did. The router acts as a DHCP server, so it automatically gives 255.255.255.0 mask and 192.168.0.X IPs.
Link Posted: 8/19/2004 10:59:32 PM EST
Link Posted: 8/20/2004 9:02:25 AM EST
Thank you Troy, that worked perfectly!

Another quick question. If I want to use a pc as a server, does it have to be "in front" of the router?
Link Posted: 8/20/2004 11:47:11 AM EST
[Last Edit: 8/20/2004 11:49:07 AM EST by Troy]
Top Top