Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
9/22/2017 12:11:25 AM
Posted: 8/30/2005 7:15:34 AM EDT
The machine is a P200 with 64 megs and various ISA & PCI devices, running Win98SE.

An unidentified device is causing an errror message that indicate that the modem or port (COM4) is already in use when you try to use the internal modem in an ISA slot. The machine is 2000 miles away, BTW.

Maybe more deleting of drivers for previous devices is in order, but how would you identify the offender - can't seem to pinpoint it in CP-system-device manager. Looked both by device and by connection & don't see an obvious problem.

Thanks,


Gotta go



PRK
Link Posted: 8/31/2005 11:34:38 PM EDT
^
Link Posted: 8/31/2005 11:39:15 PM EDT
P200? Win98? Holy hell. Anyhting I knew about that I forgot long ago. Sorry.

Wait...2000 miles away?
Link Posted: 9/1/2005 12:53:41 AM EDT
Changes? Did it ever work? Is the internal modem new and you need a new port?

Get someone at the keyboard that will patiently follow directions and read the screen to you. (I refuse to support my brother cause I'll hear typing and he'll say "I'm trying something". Done - call me back when your done tryin' stuff!) Always helps if you follow along on your computer.

Ideas:
COM ports are typically serial ports, modems, IRDA connections etc. You get 4 ports only. Remember what you do (so you can put it back if needed).

BTW old modem cards may not be selectable in software may require jumper or dip switch change on card. Also you may need to change the IRQ also (these are limited also). Newer computers and OS's scale better with all the crap we hang on 'em.

Option 1
Note my version of Windows differs. In "Device Manager" check out "Ports (COM and LPT)", "Communications ports", "Port Settings", "Advanced" - COM Port setting should list current port for chosen device and all ports used. Are all 4 used? You can manually rearrange ports - perhaps multiple ports want port 4 as a default.

Option 2
Your machine may have a serial port unused in back (or your mouse may be connected to it).

If you have an empty serial port in back (usually a 9pin plug like a small parallel printer plug) it is likely using a com port set in the BIOS.

BIOS - You know when you boot and it says something like "F1 for Setup", this is the hardware boot defaults in your machine. Tells the machine how to use the harddrive etc. before the OS loads. Remember you must save the settings.

Check it out, quickly on boot hit whatever key it says gets you to setup. Remember you don't have an OS yet so no mouse - follow lousy instructions - they are all different. Disable the serial port (usually something like Com port 1, Com port 2, disable).
Boot Windows see if it rearranges properly or you can rearrange the ports manually.

OPtion 3
If you have an option "PnP OS" (plug and play OS) select it. This will give WIN98 control over all devices. This will likely cause WIN98 to redo all its device ports because it can rearrange things that were set by the BIOS.

Best Option
Just a plug for Dell... Dimension 2400 $299 (with $75 rebate that you really get) plus shipping. Complete system modern, entry level for today - a dozen times bigger and faster than your 200! Unpack and it works! Decide how much hassle the old 200 is worth!


Luck!


Link Posted: 9/1/2005 2:15:26 AM EDT
The modem came from another old computer and the drivers were downloaded from Creative Labs. the newphew looked for jumpers and didn't see any. The only modem this computer ever had were externals plugged into com1 or com2. The mouse has its own separate port.

The bios was checked and we tried switching to the forced "ISA device present" (vs. 'no/ICU') IRQ11 setting. Also we tried a complete 'delete' of the modem in safe mode following the instructions from Creative, then reinstalling it. Also tried disabling COM2 (nothing is attached there) as it seems to pair with COM4, the port that can't be opened.

We'll take another look at the ports under 'advanced'. There is an error message that says port 4 is already in use by another device. A friend suggesteed making sure one of the other cards like the soundcard or the 3D card is causing this. We'll see - the guy on the keyboard is great - especially his deliberate manner.

Link Posted: 9/1/2005 10:14:36 AM EDT
I don't think the problem is windows. You said this is a 200mhz system. BIOS used to assign motherboard peripheral resources. Windows is trying to make all devices happy even though it doesn't control all mapping.

"ISA device present" (vs. 'no/ICU') IRQ11 Old Motherboards got around ISA conflicts by using mapping software. But this is usually not "let plug and play OS map resources". It is usually a sofware that you manually map. For example, Intel - http://developer.intel.com/design/motherbd/gen_indx.htm

Newer hardware was plug and play aware and you could let the OS map all resources.
Newer OS's finally dropped most ISA support
http://download.microsoft.com/download/1/6/1/161ba512-40e2-4cc9-843a-923143f3456c/ISAW2.doc

Anyway I have always been able to fall back on the basics and you seem to have 1 of two things going on.

All ports are already used and you have to remove something. In BIOS could you disable the serial ports out the back? Even without anything connected they are assigned resources. Usually something like Integrated Serial Port and assigned COM1 COM2 Disabled. This would disable the device (serial port) and free up the COM port.

Or two devices are clashing over same port and you have to change one. Can you manually rearrange ports and IRQs? I have seen deadlocks (especially with ISA as mentioned above) where 2 devices required the same resources and just couldn't be used together.

Luck!
Top Top