Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Site Notices
Posted: 6/15/2009 5:33:41 PM EST
History: Feb 2008 front end accident requires major disassembly and reconstruction. It did not rupture the radiator, but I don't remember if it was replaced or not.
Get it back a month later, no overheating problems until

Sept 2008, while pulling an empty single axle cargo trailer 45 miles, it started overheating bad about 20 minutes into the trip. Normally gauge is half way, it started averaging 3/4 and was hitting overtemp unless I drove 40mph.
w/o trailer, rest of the year and this year until yesterday were fine.

Yesterday, drove 4hrs before making a wrong turn and getting frustrated. During detour to get back on course, I was rather rough with the throttle, and it went to like 7/8 and no matter how nice I drove, it never went much below 3/4 unless I was coasting down a long hill. As soon as I got on the throttle, it would climb back over 3/4. Parked it, let it sit for 20 minutes or so, restarted and it went to overtemp for about 20 seconds or so and then back down below 3/4.

Today, I went out and looked to see if I had an air pocket. Pulled the bleeder off the top of the radiator, started it from cold and allowed it to warm up to normal half way. I did manage to drain about 2 cups of fluid onto the ground and the fluid level light came on. Refilling reservoir solved that. Didn't seem to find an air pocket.

Any suggestions?
Top Top