Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Posted: 1/29/2011 4:11:44 AM EDT
[Last Edit: 1/29/2011 9:13:00 AM EDT by genesis]
I just put a new trans (Allison) in my buddies 2004 Chevy HD 4X4.
Does anyone know how much fluid this thing holds?
I already have 12 qts in it and it's still WAY low on the dipstick.


Title edit...truck won't move.
Link Posted: 1/29/2011 4:59:32 AM EDT
I put an Allison in a Duramax truck two weeks ago and it took 17qts. IIRC.
Link Posted: 1/29/2011 5:09:21 AM EDT

Originally Posted By paul463:
I put an Allison in a Duramax truck two weeks ago and it took 17qts. IIRC.

Thanks!
Link Posted: 1/29/2011 5:15:42 AM EDT
Amsoil has a great "fluid capacity" website. http://www.amsoil.com/mygarage

They list the Allison 1000 as taken less fluid than a 4L80-E, which I know is bullshit.

I just keep adding until it reached the full mark, when they're brand new you'll be amazed how much fluid they take. I installed a rebuilt 700R4 years ago, with a deep pan from B&M, it took 17.5 quarts.
Link Posted: 1/29/2011 5:17:30 AM EDT

Originally Posted By txgp17:
Amsoil has a great "fluid capacity" website. http://www.amsoil.com/mygarage

They list the Allison 1000 as taken less fluid than a 4L80-E, which I know is bullshit.

I just keep adding until it reached the full mark, when they're brand new you'll be amazed how much fluid they take. I installed a rebuilt 700R4 years ago, with a deep pan from B&M, it took 17.5 quarts.

Good info, thanks.

I knew we were in trouble when he showed up with 1 case of fluid.
Link Posted: 1/29/2011 7:17:42 AM EDT
well shit.
After dumping 17 qts in this thing the dipstick says its full and the damn thing wont move.
When you put it in rev it "clunks" like its in gear but will not move.
When you put it in drive it "clunks and barely moves.

I don't know how the hell I got myself into this project to begin with.
Link Posted: 1/29/2011 11:13:26 AM EDT
Fixed it.
My buddy is a meathead and did not connect the wires on the bell housing.

works like a million bucks now.
Link Posted: 1/29/2011 11:16:35 AM EDT

Originally Posted By genesis:
Fixed it.
My buddy is a meathead and did not connect the wires on the bell housing.

works like a million bucks now.


Wires? You wire tied this to the engine? Damn.
Link Posted: 1/29/2011 12:14:40 PM EDT
Originally Posted By genesis:
Fixed it.
My buddy is a meathead and did not connect the wires on the bell housing.

works like a million bucks now.


Glad you got it figured out. I have never torn into an allison but from what I have read it is fairly simple.

What was wrong with it in the first place? Did he upgrade for HP reasons? Did he upgrade to the 05+ allisons with the 6th speed?
Link Posted: 1/30/2011 1:38:46 AM EDT
[Last Edit: 1/30/2011 1:39:52 AM EDT by genesis]

Originally Posted By tothemax:
Originally Posted By genesis:
Fixed it.
My buddy is a meathead and did not connect the wires on top of the the bell housing.

works like a million bucks now.


Glad you got it figured out. I have never torn into an allison but from what I have read it is fairly simple.

What was wrong with it in the first place? Did he upgrade for HP reasons? Did he upgrade to the 05+ allisons with the 6th speed?

It was a very simple ordeal.
The only thing remotely difficult would be the shear weight of the damn thing.

He upgraded because he got a new EFI live tuner and didn't want to junk the old trans.
He did not get the 6 spd upgrade.

We also did the T case pump rub upgrade while we had it out.
Link Posted: 1/30/2011 7:49:05 AM EDT
Originally Posted By genesis:

Originally Posted By tothemax:
Originally Posted By genesis:
Fixed it.
My buddy is a meathead and did not connect the wires on top of the the bell housing.

works like a million bucks now.


Glad you got it figured out. I have never torn into an allison but from what I have read it is fairly simple.

What was wrong with it in the first place? Did he upgrade for HP reasons? Did he upgrade to the 05+ allisons with the 6th speed?

It was a very simple ordeal.
The only thing remotely difficult would be the shear weight of the damn thing.

He upgraded because he got a new EFI live tuner and didn't want to junk the old trans.
He did not get the 6 spd upgrade.

We also did the T case pump rub upgrade while we had it out.


Excellent. I want to upgrade to the 6spd in the near future.

I dont run a lot of hp (around 100hp with the edge) so I dont need a full blown transmission upgrade.
Link Posted: 1/30/2011 9:43:48 AM EDT

Originally Posted By tothemax:
Originally Posted By genesis:

Originally Posted By tothemax:
Originally Posted By genesis:
Fixed it.
My buddy is a meathead and did not connect the wires on top of the the bell housing.

works like a million bucks now.


Glad you got it figured out. I have never torn into an allison but from what I have read it is fairly simple.

What was wrong with it in the first place? Did he upgrade for HP reasons? Did he upgrade to the 05+ allisons with the 6th speed?

It was a very simple ordeal.
The only thing remotely difficult would be the shear weight of the damn thing.

He upgraded because he got a new EFI live tuner and didn't want to junk the old trans.
He did not get the 6 spd upgrade.

We also did the T case pump rub upgrade while we had it out.


Excellent. I want to upgrade to the 6spd in the near future.

I dont run a lot of hp (around 100hp with the edge) so I dont need a full blown transmission upgrade.
It looks like a worthwhile upgrade, I don't know why he didn't do it while we had it out.
W got a Harbor Freight tranny jack and I tell you it was worth it's weight in gold.

Have you done the pump rub upgrade in your transfer yet?
That was about a 15 minute job with it already out of the truck.

Link Posted: 1/30/2011 4:47:47 PM EDT
Originally Posted By genesis:

Originally Posted By tothemax:
Originally Posted By genesis:

Originally Posted By tothemax:
Originally Posted By genesis:
Fixed it.
My buddy is a meathead and did not connect the wires on top of the the bell housing.

works like a million bucks now.


Glad you got it figured out. I have never torn into an allison but from what I have read it is fairly simple.

What was wrong with it in the first place? Did he upgrade for HP reasons? Did he upgrade to the 05+ allisons with the 6th speed?

It was a very simple ordeal.
The only thing remotely difficult would be the shear weight of the damn thing.

He upgraded because he got a new EFI live tuner and didn't want to junk the old trans.
He did not get the 6 spd upgrade.

We also did the T case pump rub upgrade while we had it out.


Excellent. I want to upgrade to the 6spd in the near future.

I dont run a lot of hp (around 100hp with the edge) so I dont need a full blown transmission upgrade.
It looks like a worthwhile upgrade, I don't know why he didn't do it while we had it out.
W got a Harbor Freight tranny jack and I tell you it was worth it's weight in gold.

Have you done the pump rub upgrade in your transfer yet?
That was about a 15 minute job with it already out of the truck.



No I have not yet done that upgrade. It is also on the to do list....
Top Top