Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Site Notices
Posted: 6/17/2009 6:07:34 AM EST
[Last Edit: 6/17/2009 6:09:49 AM EST by greco]
As I mentioned before, I'm not an FAL expert, so I need some help. Recently I bought a a Century/Imbel which I have shot about 200 rounds thru. I have cleaned it several times, and had it apart just playing with it. I put 5 rounds thru it at the range the other day and came home. (I went to shoot a pistol for function). Anyway, I wanted to clean the FAL out even if I only shot 5 rounds thru it. So I pressed the latch, and it won't open. So I held the latch back and pressed with my foot a little, then more. Nothing. When you pull the latch back it moves just a fraction, so it is not solidly in place, but won't go past that. I thought the spring or the rat tail on the bolt might be in the way, so I pulled the spring assembly out of the stock, and that didn't help. I can cock it and shoot it just fine. The bolt comes back just fine. But it won't break open...any ideas????? Nothing on the search about this. thanks gn

Oh, and I took the pivot bolt/screw (takedown pin) out. No help.
Link Posted: 6/17/2009 9:01:32 AM EST
Some FAL's can be a little tight. My R1 on a DSA receiver needs to be broken open over the knee to open it. Eventually, it will wear in a little bit. If the latch is not moving back all the way, take the stock off and take out all the latch components and see what's going on. Hope this helps.
Link Posted: 6/17/2009 11:52:47 AM EST
Well, I couldn't think of anything that might hold up the process, so I compared it to one of my DSA's. It looked like the latch didn't go back as far. So I pulled the stock off, (an aftermarket DSA stock that I had installed a few days ago). Guess what, worked like it should. So I drilled out a little to give the latch plenty of room to move back. Problem solved...

Lew you hit it right on the head.
Link Posted: 6/18/2009 8:55:27 AM EST


Now that will be $50 for my time and effort. Have fun.
Top Top