Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
10/20/2017 1:01:18 AM
9/22/2017 12:11:25 AM
Page / 21
Next Page Arrow Left
Link Posted: 2/16/2017 5:14:59 PM EDT
Link Posted: 2/16/2017 8:11:33 PM EDT
Ok, so you either bracket horizonal or vertical. Both at the same time though? Hopefully it will come with instructions
Link Posted: 2/16/2017 11:10:04 PM EDT
Link Posted: 2/16/2017 11:35:35 PM EDT
Thanks!
Link Posted: 3/17/2017 5:26:29 PM EDT
Link Posted: 4/25/2017 1:11:23 PM EDT
Link Posted: 4/25/2017 3:10:27 PM EDT
Nice! Let's see a video.
Link Posted: 4/25/2017 10:13:27 PM EDT
I called Trijicon and they had IRD/Trijicon in Cali mail me a manual. I had it in less than a week. It's very nice compared to the shitty laminate quick start guide.
Link Posted: 4/25/2017 11:26:38 PM EDT
Link Posted: 5/3/2017 8:10:30 PM EDT
Are any of you REAP-IR users having issues with the menu popping up from the recoil jostling the jpystick?
Link Posted: 5/4/2017 5:44:33 PM EDT
Discussion ForumsJump to Quoted PostQuote History
Originally Posted By cmatera:
Are any of you REAP-IR users having issues with the menu popping up from the recoil jostling the jpystick?
View Quote
You can turn that feature off in the menu.
Link Posted: 5/6/2017 10:53:01 AM EDT
Only issue I have had, is the screen splitting at start up; then not having an image after it is powered up. You can go through the menus and clearly see the menu labels, but the image is not there. I call Trijicon, but still waiting to here back about the issue. I tried restarting many times and it did not help. Started it up again a couple days ago and it was back to "normal", so not sure what is going on there.

If anyone else has had this issue, please chime in.
Link Posted: 5/8/2017 2:40:25 PM EDT
Discussion ForumsJump to Quoted PostQuote History
Originally Posted By leotrainer1:
Only issue I have had, is the screen splitting at start up; then not having an image after it is powered up. You can go through the menus and clearly see the menu labels, but the image is not there. I call Trijicon, but still waiting to here back about the issue. I tried restarting many times and it did not help. Started it up again a couple days ago and it was back to "normal", so not sure what is going on there.

If anyone else has had this issue, please chime in.
View Quote
I'm not sure if I understand the problem. So when you start it up, you get a blank screen with the menu still overlayed as normal? Do you have the front scope cover closed while starting up?
Link Posted: 5/8/2017 9:29:13 PM EDT
Discussion ForumsJump to Quoted PostQuote History
Originally Posted By leotrainer1:
Only issue I have had, is the screen splitting at start up; then not having an image after it is powered up. You can go through the menus and clearly see the menu labels, but the image is not there. I call Trijicon, but still waiting to here back about the issue. I tried restarting many times and it did not help. Started it up again a couple days ago and it was back to "normal", so not sure what is going on there.

If anyone else has had this issue, please chime in.
View Quote
Try fresh batteries. It gets finiky at the lower spectrum of the battery life
Link Posted: 5/9/2017 3:24:55 PM EDT
Yes, cap closed and full external battery pack. Upon start up, picture on screen is split. Once fully on, the screen is grey static signal, but can still toggle through the menus.
Link Posted: 6/15/2017 10:24:54 PM EDT
Link Posted: 7/2/2017 1:09:55 PM EDT
Link Posted: 7/2/2017 2:13:21 PM EDT
Discussion ForumsJump to Quoted PostQuote History
Originally Posted By TNVC:
What was the outcome of this?
View Quote View All Quotes
View All Quotes
Discussion ForumsJump to Quoted PostQuote History
Originally Posted By TNVC:
Originally Posted By leotrainer1:
Yes, cap closed and full external battery pack. Upon start up, picture on screen is split. Once fully on, the screen is grey static signal, but can still toggle through the menus.
What was the outcome of this?
#leotrainer1
Link Posted: 7/2/2017 5:38:08 PM EDT
Just got it back yesterday, but they did not say what the issue was. I had even asked in an email I had sent when requesting RMA number.
Link Posted: 7/6/2017 3:20:48 PM EDT
Discussion ForumsJump to Quoted PostQuote History
Originally Posted By leotrainer1:
Just got it back yesterday, but they did not say what the issue was. I had even asked in an email I had sent when requesting RMA number.
View Quote
So, did they get it fixed and is it working up to your expectations now?
Link Posted: 7/31/2017 2:29:44 PM EDT
[Last Edit: 7/31/2017 2:35:10 PM EDT by TNVC]
Link Posted: 8/1/2017 11:54:29 AM EDT
Link Posted: 8/22/2017 6:06:12 PM EDT
[Last Edit: 8/22/2017 6:06:47 PM EDT by TNVC]
Link Posted: 10/5/2017 2:14:26 PM EDT
Link Posted: 10/5/2017 2:35:54 PM EDT
Discussion ForumsJump to Quoted PostQuote History
Originally Posted By TNVC:
Tom Austin from our sister company NightGoggles only likes hunting on the days ending in "Y".

http://www.ar15.com/media/mediaFiles/19096/Triji_M-287704.jpg
View Quote
That is clearly a SilencerCo Harvester on an SBR. It's not rated for that. Is it working ok in this config? Any significant baffle erosion?

Asking for a friend :)
Link Posted: 10/5/2017 3:06:07 PM EDT
[Last Edit: 10/5/2017 3:07:37 PM EDT by NGI_TOM]
Link Posted: 10/8/2017 12:58:08 AM EDT
Discussion ForumsJump to Quoted PostQuote History
I haven't been keeping up with the updates, what's on the end of the unit on the left?
Link Posted: 10/8/2017 12:32:18 PM EDT
Page / 21
Next Page Arrow Left
Top Top