Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Site Notices
Posted: 11/14/2008 2:17:35 PM EDT
[Last Edit: 11/15/2008 2:45:57 PM EDT by ak007]
The thing only has one screw and a tab that goes over the top of the receiver. If I put the long screw through the right side of the receiver and thread it into the saddle's plate that is fine...The thing is not going to move farward, back or down...But it will rotate up, counter-clockwise. So am I just dumb or what? There are no other screw holes in the receiver or saddle plate, so what I see is what I got. Help?!?


In this pic you can see the screw and the tab. The fingers point to them.


In this pic you can see the prob. It is secured in all directions but up.
Link Posted: 11/15/2008 11:38:11 AM EDT
Having trouble picturing what exactly you've got. Posting a picture or a link to what you have might help.
Link Posted: 11/15/2008 7:25:01 PM EDT
Anyone?
Link Posted: 11/15/2008 8:59:52 PM EDT
I had one of those on my old 1300 and there should be another little tab on the bottom of the shell holder that hooks where you load the shells (I'm terrible with gun terminology). Anyway, it was pretty secure with both hooks. I'm wondering if yours doesn't have one because I know it should. Maybe you should take it back.
Link Posted: 11/16/2008 4:21:32 AM EDT
Originally Posted By CaptShiess:
I had one of those on my old 1300 and there should be another little tab on the bottom of the shell holder that hooks where you load the shells (I'm terrible with gun terminology). Anyway, it was pretty secure with both hooks. I'm wondering if yours doesn't have one because I know it should. Maybe you should take it back.


Ditto. The 2nd attachment point on these is supposed to be a clip that hooks into the bottom of the receiver. That's how it is on my 1300. It's still kinda loose though because of the design of that top tab. I wish there was a better attachment point on the top edge but that would require drilling the receiver or something.
Link Posted: 11/17/2008 11:55:29 AM EDT
So could this be just the wrong one? Or a defect?
Link Posted: 11/18/2008 8:35:56 PM EDT
My 1300's side saddle is the same as Gendel.

SMSP
Link Posted: 11/19/2008 2:13:09 PM EDT
Ok thanks guys.
Link Posted: 11/19/2008 5:41:56 PM EDT
Maybe a piece of double stick tape would help.

What's the deal with the silver screws?
Link Posted: 11/21/2008 6:14:07 AM EDT
Originally Posted By CaptShiess:
I had one of those on my old 1300 and there should be another little tab on the bottom of the shell holder that hooks where you load the shells (I'm terrible with gun terminology). Anyway, it was pretty secure with both hooks. I'm wondering if yours doesn't have one because I know it should. Maybe you should take it back.


I have the same Tacstar SideSaddle on my FN TPS (win 1300 base) and it also has a tab on the bottm by the shell loading port... Mine is rock solid so far..
ETA.. Quick pic so you get an idea of how/where it fits..
http://i188.photobucket.com/albums/z156/OKCWizzard/FN%20TPS/DSC00837a.jpg
http://i188.photobucket.com/albums/z156/OKCWizzard/FN%20TPS/DSC00838a.jpg
http://i188.photobucket.com/albums/z156/OKCWizzard/FN%20TPS/DSC00844a.jpg
Top Top