Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 8/22/2005 6:43:08 PM EDT
Posted this across the street but never got an answer, so I'll try here. As some might know, I just got my first M1A. Got it on Gunbroker. Wasn't listed as having a scope mount with it, but when the rifle got here it had a SA Gen ? mount. Since I'm going to send it in for the bolt recall I was going to take it off tonite. Mount is off, but the bracket that goes thru the stripper clip guide is still on. How is this held in place? Looks like theres a pin or set screw thru the bracket , down to and pushing on the bottom of the guide dovetail. Pin or screw, or what? Thanks Greg
Link Posted: 8/22/2005 7:05:46 PM EDT
I can't say for sure about the SA mount. Mine is SEI and has a allen head screw to tighted the clip guide fastener.

I would say to try small allen wrenchs and see if you don't find that one will fit. I don't think they would roll pin the clip guide in place for their mount.

Tap out from left to right and re install right to left but I bet you find a set screw of some sort.

Karsten
Link Posted: 8/22/2005 7:26:38 PM EDT
I figured it had to be a set screw of some kind. But looking down in the hole with my magnafier/light, I can't really see any corners for the allen wrench but one side looks split like a roll pin. Tops shiny so I'm wondering if they tried to take off the mount separately to sell and broke the set screw. Might have to ask SA if they'll take it off for me. They'll already like me anyway. Going to send the rifle back in a Savage styro lined box. Only box I have around here. Might just put it in a plastic hard case and use the cardboard outer, but the rifle fits good in the styrofoam cutout. Hope I get a REAL SA box in return! Thanks Greg
Top Top